Make sure the build system honors C_INCLUDE_PATH and LIBRARY_PATH when
looking for headers and libraries.
--- a/setup.py 2015-10-07 23:32:58.891329173 +0200
+++ b/setup.py 2015-10-07 23:46:29.653349924 +0200
@@ -676,15 +676,15 @@
# if a file is found in one of those directories, it can
# be assumed that no additional -I,-L directives are needed.
if not CROSS_COMPILING:
- self.lib_dirs = self.compiler.library_dirs + system_lib_dirs
- self.inc_dirs = self.compiler.include_dirs + system_include_dirs
+ self.lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
+ self.inc_dirs = os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
else:
# Add the sysroot paths. 'sysroot' is a compiler option used to
# set the logical path of the standard system headers and
# libraries.
- self.lib_dirs = (self.compiler.library_dirs +
+ self.lib_dirs = (os.getenv('CROSS_LIBRARY_PATH', '').split(os.pathsep) +
sysroot_paths(('LDFLAGS', 'CC'), system_lib_dirs))
- self.inc_dirs = (self.compiler.include_dirs +
+ self.inc_dirs = (os.getenv('CROSS_C_INCLUDE_PATH', '').split(os.pathsep) +
sysroot_paths(('CPPFLAGS', 'CFLAGS', 'CC'),
system_include_dirs))
da15b4a7a8176d616ec92f8'>commitdiff
|
Age | Commit message (Expand) | Author |
2023-10-08 | disarchive-manifest: Add one manifest entry per tarball....This works around a situation where ‘cuirass remote-worker’ now builds
with max-jobs = 1 (Cuirass commit
980ef610989895be5ac2ba7f9d1901e5c7f22934). The effect is that all
.dis.drv would be performed sequentially, on a single machine (‘cuirass
remote-server’ is unable to distribute those derivations to several
machines because it only “sees” the ‘disarchive-collection’ derivation).
This would take a lot of time and force a rebuild of all of *.dis.drv
every time because their build results would not be retrieved by the
‘remote-server’ process.
* etc/disarchive-manifest.scm (disarchive-collection): Remove.
<top level>: Define ‘disarchives’. Append it to the entries of the
manifest.
| Ludovic Courtès |
2022-08-06 | disarchive-manifest: Exclude the Chromium tarball....* etc/disarchive-manifest.scm (disarchive-collection): Exclude
"chromium-" tarballs.
| Ludovic Courtès |
2022-08-05 | disarchive-manifest: Filter out origins without a hash....* etc/disarchive-manifest.scm (disarchive-collection): Filter out
origins with a phony hash.
| Ludovic Courtès |
2022-08-05 | disarchive-manifest: Handle tar.xz archives....* etc/disarchive-manifest.scm (tarball-origin?): Add ".tar.xz".
| Ludovic Courtès |
2021-10-09 | disarchive-manifest: Provide valid 'version' string....* etc/disarchive-manifest.scm <top level>: Turn 'version' field into a
string.
| Ludovic Courtès |
2021-09-14 | etc: Add 'disarchive-manifest.scm'....* etc/disarchive-manifest.scm: New file.
* Makefile.am (EXTRA_DIST): Add it.
| Ludovic Courtès |