Upstream status: Not upstreamed. The build system refuses to cross-compile for unknown targets even though it works fine. Add GNU/Hurd target. --- Python-3.8.5/configure.orig 2020-10-26 14:06:09.665423525 +0100 +++ Python-3.8.5/configure 2020-10-26 14:08:30.987765738 +0100 @@ -3278,6 +3278,9 @@ *-*-vxworks*) ac_sys_system=VxWorks ;; + *-*-gnu) + ac_sys_system=GNU + ;; *) # for now, limit cross builds to known configurations MACHDEP="unknown" @@ -3328,6 +3331,9 @@ *-*-vxworks*) _host_cpu=$host_cpu ;; + *-*-gnu) + _host_cpu=$host_cpu + ;; *) # for now, limit cross builds to known configurations MACHDEP="unknown" 256452932e0d8d'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/databases.scm
AgeCommit message (Collapse)Author
2020-11-28services: MySQL: Add more tests.Marius Bakke
* gnu/tests/databases.scm (run-mysql-test): Try creating a database and inserting data.
2020-11-28services: MySQL: Upgrade database schemas automatically.Marius Bakke
* gnu/services/databases.scm (<mysql-configuration>): Add AUTO-UPGRADE? field. (mysql-upgrade-wrapper, mysql-upgrade-shepherd-service, mysql-shepherd-services): New variables. (mysql-service-type): Use MYSQL-SHEPHERD-SERVICES instead of MYSQL-SHEPHERD-SERVICE. * doc/guix.texi (Database Services): Document the AUTO-UPGRADE? field of MYSQL-SERVICE-TYPE. * gnu/tests/databases.scm (run-mysql-test): Test that mysql_upgrade has run.
2020-11-28services: MySQL: Deprecate 'mysql-service'.Marius Bakke
* gnu/services/databases.scm (mysql-service): Define in terms of DEFINE-DEPRECATED. * gnu/tests/databases.scm (%mysql-os): Adjust accordingly. * doc/guix.texi (Database Services): Adjust the MariaDB/MySQL section to document MYSQL-SERVICE-TYPE instead of MYSQL-SERVICE. While at it, document the EXTRA-CONTENT field.
2020-10-20services: databases: Don't specify a default postgresql version.Christopher Baines
Currently, if the postgresql package major version changes, this is going to break the service upon upgrade, because PostgreSQL will reject the data files from the differing major version of the service. Because it's important to either keep running a particular major version, or intentionally upgrade, I think the configuration would be better with no default. I think this is also going to be helpful when trying to assist users upgrading PostgreSQL. * gnu/services/databases.scm (<postgresql-configuration>): Remove default for postgresql. (postgresql-service-type): Remove the default value. * gnu/tests/databases.scm (%postgresql-os): Update accordingly. * gnu/tests/guix.scm (%guix-data-service-os): Update accordingly. * gnu/tests/monitoring.scm (%zabbix-os): Update accordingly. * gnu/tests/web.scm (patchwork-os): Update accordingly. * doc/guix.texi (PostgreSQL): Update accordingly.