Ensure memory accesses in the sha3 module are aligned on ARM as it causes problems when running 32-bit code on a 64-bit kernel. Patch taken from upstream bug report: https://bugs.python.org/issue36515 --- a/Modules/_sha3/sha3module.c +++ b/Modules/_sha3/sha3module.c @@ -64,6 +64,12 @@ #define PLATFORM_BYTE_ORDER IS_BIG_ENDIAN #endif +/* Bus error on 32-bit ARM due to un-aligned memory accesses; 64-bit ARM + * doesn't complain but un-aligned memory accesses are sub-optimal */ +#if defined(__arm__) || defined(__aarch64__) +#define NO_MISALIGNED_ACCESSES +#endif + /* mangle names */ #define KeccakF1600_FastLoop_Absorb _PySHA3_KeccakF1600_FastLoop_Absorb #define Keccak_HashFinal _PySHA3_Keccak_HashFinal n value='koszko' selected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/.dir-locals.el
AgeCommit message (Expand)Author
2019-09-23git: Add 'commit-difference'....Ludovic Courtès
2019-06-05syscalls: Add 'with-file-lock' macro....Ludovic Courtès
2019-05-27publish: Add support for lzip....Ludovic Courtès
2019-03-07database: Make 'register-items' transactional....Caleb Ristvedt
2019-01-11status: Add 'with-status-verbosity'....Ludovic Courtès
2018-10-19tests: Run 'guix pack' tests using the external store....Ludovic Courtès
2018-09-27Add (guix status) and use it for pretty colored output....Ludovic Courtès
2018-06-01Add (gnu store database)....Caleb Ristvedt
2018-06-01gexp: Add 'with-extensions'....Ludovic Courtès
2018-01-08services: guix: Add 'log-compression' option....Ludovic Courtès
2017-12-01weather: Use (guix progress) for progress report....Ludovic Courtès
2017-05-18union: Gracefully handle dangling symlinks in the input....Ludovic Courtès
2017-05-04dir-locals.el: Add 'modify-phases' keywords....Alex Kost
2017-04-18Add (guix workers)....Ludovic Courtès