Make sure the build system honors C_INCLUDE_PATH and LIBRARY_PATH when looking for headers and libraries. --- Python-2.7.10/setup.py 2015-10-07 18:33:18.125153186 +0200 +++ Python-2.7.10/setup.py 2015-10-07 18:33:47.497347552 +0200 @@ -526,6 +526,14 @@ class PyBuildExt(build_ext): inc_dirs += ['/system/include', '/atheos/autolnk/include'] inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep) + # Always honor these variables. + if not cross_compiling: + lib_dirs += os.getenv('LIBRARY_PATH', '').split(os.pathsep) + inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep) + else: + lib_dirs = os.getenv('CROSS_LIBRARY_PATH', '').split(os.pathsep) + inc_dirs = os.getenv('CROSS_CPATH', '').split(os.pathsep) + # OSF/1 and Unixware have some stuff in /usr/ccs/lib (like -ldb) if host_platform in ['osf1', 'unixware7', 'openunix8']: lib_dirs += ['/usr/ccs/lib'] e>
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
AgeCommit message (Expand)Author
2024-10-30gnu: diffoscope: Update to 282....* gnu/packages/diffoscope.scm (diffoscope): Update to 282. Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn> Vagrant Cascadian
2024-09-09gnu: trydiffoscope: Update Style....* gnu/packages/diffoscope.scm (reprotest): Reindent. [arguments]: Use G-expression. Remove trailing #t. Change-Id: I5d77472405adcca35eca7bed9663f30f1f8ed18e Zheng Junjie
2024-09-09gnu: trydiffoscope: Update to 67.0.8....* gnu/packages/diffoscope.scm (trydiffoscope): Update to 67.0.8. Vagrant Cascadian
2024-09-09gnu: reprotest: Use G-expression....* gnu/packages/diffoscope.scm (reprotest)[arguments]: Use G-expression. Change-Id: I35d4673e39a449169f5a66265e486d8e45268425 Zheng Junjie
2024-09-09gnu: reprotest: Simplify native-inputs....* gnu/packages/diffoscope.scm (reprotest): Simplify native-inputs. Change-Id: Ia443fb9369e65e686d619acaffa60c130a5503cf Zheng Junjie
2024-09-09gnu: reprotest: Update to 0.7.28....* gnu/packages/diffoscope.scm (reprotest): Update to 0.7.28. [arguments]<#:phases>: Remove adjust-locales phase. Change-Id: I11a0fd6fa9dae47bb5748dd404856d07a3b08b0c Vagrant Cascadian
2024-09-03gnu: diffoscope: Update to 277....* gnu/packages/diffoscope.scm (diffoscope): Update to 277. Vagrant Cascadian
2024-08-18gnu: diffoscope: Update to 276....* gnu/packages/diffoscope.scm (diffoscope): Update to 276. Change-Id: I15c5e4b283f79c8d7ce16165f3d2d39200a63810 Tobias Geerinckx-Rice
2024-07-05ugnu: diffoscope: Update to 272....Fixes: https://issues.guix.gnu.org/71886 * gnu/packages/diffoscope.scm (diffoscope): Update to 272. Vagrant Cascadian