SIGINT is ignored in the Guix build environment. --- a/Lib/test/test_regrtest.py +++ b/Lib/test/test_regrtest.py @@ -399,6 +399,8 @@ output = self.run_tests('--fromfile', filename) self.check_executed_tests(output, tests) + @unittest.skipIf(True, + "KeyboardInterrupts do not work in the build environment") def test_interrupted(self): code = TEST_INTERRUPTED test = self.create_test('sigint', code=code) @@ -416,6 +418,8 @@ % (self.TESTNAME_REGEX, len(tests))) self.check_line(output, regex) + @unittest.skipIf(True, + "KeyboardInterrupts do not work in the build environment") def test_slow_interrupted(self): # Issue #25373: test --slowest with an interrupted test code = TEST_INTERRUPTED ct> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/etc
AgeCommit message (Expand)Author
2017-01-20etc: indent-code.el: Add indentation info for non-Guix Scheme constructs....Ludovic Courtès
2017-01-13etc: Support indentation of whole files....Ludovic Courtès
2017-01-12etc: Add 'indent-package.el' script....Ludovic Courtès
2017-01-04doc: Add a Git hook that verifies signatures before pushing....Leo Famulari
2016-11-24Add system start-up files for "guix publish"....Hartmut Goebel
2016-09-07bash completion: Complete subcommands and their options....Ludovic Courtès
2016-09-07bash completion: Redirect 'guix' stderr to /dev/null....Ludovic Courtès
2016-09-07Add Zsh completion file....Eric Le Bihan