SIGINT is ignored in the Guix build environment. --- a/Lib/test/test_regrtest.py +++ b/Lib/test/test_regrtest.py @@ -399,6 +399,8 @@ output = self.run_tests('--fromfile', filename) self.check_executed_tests(output, tests) + @unittest.skipIf(True, + "KeyboardInterrupts do not work in the build environment") def test_interrupted(self): code = TEST_INTERRUPTED test = self.create_test('sigint', code=code) @@ -416,6 +418,8 @@ % (self.TESTNAME_REGEX, len(tests))) self.check_line(output, regex) + @unittest.skipIf(True, + "KeyboardInterrupts do not work in the build environment") def test_slow_interrupted(self): # Issue #25373: test --slowest with an interrupted test code = TEST_INTERRUPTED ts'>koszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
AgeCommit message (Expand)Author
2022-11-10gnu: scdoc: Update to 1.11.2....Imran Iqbal
2022-10-09gnu: man-pages: Use LIST of arguments....Tobias Geerinckx-Rice
2022-10-09gnu: man-pages: Update to 6.00....Tobias Geerinckx-Rice
2022-09-08gnu: man-pages: Update to new style....Lilah Tascheter
2022-09-08gnu: Add man-pages-posix....Lilah Tascheter
2022-03-22gnu: man-db: Simplify 'patch-test-shebangs' phase....Maxim Cournoyer
2022-03-21gnu: man-db: Update to 2.10.2, enable support for zstd and libseccomp....Maxim Cournoyer
2022-01-10gnu: help2man: Update to 1.48.5....Maxim Cournoyer
2022-01-08gnu: man-db: Fix cross-compilation....Tobias Geerinckx-Rice
2022-01-08gnu: man-db: Use G-expressions....Tobias Geerinckx-Rice