SIGINT is ignored in the Guix build environment. --- a/Lib/test/test_regrtest.py +++ b/Lib/test/test_regrtest.py @@ -399,6 +399,8 @@ output = self.run_tests('--fromfile', filename) self.check_executed_tests(output, tests) + @unittest.skipIf(True, + "KeyboardInterrupts do not work in the build environment") def test_interrupted(self): code = TEST_INTERRUPTED test = self.create_test('sigint', code=code) @@ -416,6 +418,8 @@ % (self.TESTNAME_REGEX, len(tests))) self.check_line(output, regex) + @unittest.skipIf(True, + "KeyboardInterrupts do not work in the build environment") def test_slow_interrupted(self): # Issue #25373: test --slowest with an interrupted test code = TEST_INTERRUPTED s customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
AgeCommit message (Expand)Author
2024-08-31gnu: Use 'gtk-doc/stable' in native-inputs instead of 'gtk-doc'....Maxime Devos
2024-08-31gnu: photo: Add 'bash' input for 'wrap-program'....Maxime Devos
2024-08-22gnu: darktable: Update to 4.8.1....Alex Devaure
2024-07-18gnu: libraw: Update to 0.21.2....Zheng Junjie
2024-07-03gnu: darktable: Update to 4.8.0....Alex Devaure
2024-06-24gnu: rawtherapee: Update to 5.10....Sharlatan Hellseher
2024-05-21gnu: enblend-enfuse: Build with librsvg-for-system....Efraim Flashner
2024-03-09gnu: darktable: Update to 4.6.1....Alex Devaure
2024-01-19gnu: darktable: Update to 4.6.0....Vinicius Monego
2024-01-19gnu: darktable: Enable more optional features....Vinicius Monego
2024-01-19gnu: darktable: Build with GCC....Vinicius Monego
2024-01-17gnu: perl-image-exiftool: Update to 12.70....kiasoc5
2023-09-17gnu: enblend-enfuse: Build documentation....Bruno Victal
2023-09-17gnu: enblend-enfuse: Backport upstream fixes....Bruno Victal
2023-08-21gnu: darktable: Enable building on riscv64-linux....Efraim Flashner
2023-08-18gnu: darktable: Build with librsvg-for-system....Efraim Flashner
2023-08-15gnu: rawtherapee: Build with librsvg-for-system....Efraim Flashner
2023-08-13gnu: entangle: Update package style....Tobias Geerinckx-Rice
2023-08-13gnu: entangle: Fix build....Tobias Geerinckx-Rice