SIGINT is ignored in the Guix build environment. --- a/Lib/test/test_regrtest.py +++ b/Lib/test/test_regrtest.py @@ -399,6 +399,8 @@ output = self.run_tests('--fromfile', filename) self.check_executed_tests(output, tests) + @unittest.skipIf(True, + "KeyboardInterrupts do not work in the build environment") def test_interrupted(self): code = TEST_INTERRUPTED test = self.create_test('sigint', code=code) @@ -416,6 +418,8 @@ % (self.TESTNAME_REGEX, len(tests))) self.check_line(output, regex) + @unittest.skipIf(True, + "KeyboardInterrupts do not work in the build environment") def test_slow_interrupted(self): # Issue #25373: test --slowest with an interrupted test code = TEST_INTERRUPTED cripts'>koszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cdrom.scm
AgeCommit message (Expand)Author
2020-11-08gnu: cdemu-client: Update source URI....Efraim Flashner
2020-11-08gnu: cdemu-daemon: Use sourceforge mirror....Efraim Flashner
2020-11-08gnu: libmirage: Update source URI....Efraim Flashner
2020-10-16gnu: asunder: Update to 2.9.7....Tobias Geerinckx-Rice
2020-07-12gnu: Remove ".git" from "https://github/…/….git"....Ludovic Courtès
2020-06-21gnu: Add cdrdao....Timotej Lazar
2020-06-02gnu: asunder: Update to 2.9.6....Tobias Geerinckx-Rice
2020-05-13mailmap: Update entries for Nikita....nikita
2020-04-11Merge branch 'master' into core-updatesMarius Bakke
2020-04-10gnu: xorriso: Build gui frontend....Efraim Flashner
2020-04-08Merge branch 'master' into core-updates...Marius Bakke
2020-04-04gnu: Replace uses of 'gettext' with 'gettext-minimal'....Marius Bakke
2020-03-14Merge branch 'master' into core-updatesMarius Bakke
2020-03-14gnu: cdparanoia: Use HTTPS home page....Tobias Geerinckx-Rice