SIGINT is ignored in the Guix build environment. --- a/Lib/test/test_regrtest.py +++ b/Lib/test/test_regrtest.py @@ -399,6 +399,8 @@ output = self.run_tests('--fromfile', filename) self.check_executed_tests(output, tests) + @unittest.skipIf(True, + "KeyboardInterrupts do not work in the build environment") def test_interrupted(self): code = TEST_INTERRUPTED test = self.create_test('sigint', code=code) @@ -416,6 +418,8 @@ % (self.TESTNAME_REGEX, len(tests))) self.check_line(output, regex) + @unittest.skipIf(True, + "KeyboardInterrupts do not work in the build environment") def test_slow_interrupted(self): # Issue #25373: test --slowest with an interrupted test code = TEST_INTERRUPTED ko-scripts'>koszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/linux-boot.scm
AgeCommit message (Expand)Author
2022-03-01initrd: Honor rootfstype and rootflags command-line parameters....Maxim Cournoyer
2022-03-01initrd: Use non-hyphenated kernel command-line parameter names....Maxim Cournoyer
2022-02-17build: linux-boot: Expound docstring of the 'boot-system' procedure....Maxim Cournoyer
2021-09-23syscalls: Deduplicate device number conversion....Tobias Geerinckx-Rice
2021-09-23linux-boot: Honour fsck.mode & fsck.repair....Tobias Geerinckx-Rice
2021-09-23file-systems: Support forced checks & repairs....Tobias Geerinckx-Rice
2021-09-12linux-boot: Remove mummified comment....Tobias Geerinckx-Rice
2021-06-16gnu: Respect ‘rootdelay’ kernel command-line argument....Tobias Geerinckx-Rice
2021-05-23gnu: Respect the root file-system's CHECK? field....Tobias Geerinckx-Rice
2020-12-17linux-boot: Fix noresume argument parsing....Tobias Geerinckx-Rice
2020-11-07linux-boot: Resume from hibernation....Tobias Geerinckx-Rice
2020-09-07linux-boot: Handle nfs-root device strings....Stefan
2020-06-08hurd-boot: Further cleanup of "rc"....Jan (janneke) Nieuwenhuizen
2020-06-08linux-boot: Update 'make-hurd-device-nodes'....Jan (janneke) Nieuwenhuizen