These tests require a gpg agent to run, and are difficult to get to work right in Guix's environment. For more details, see: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=713074 https://bugs.launchpad.net/pygpgme/+bug/999949 --- pygpgme-0.3/tests/test_encrypt_decrypt.py 2012-02-28 19:10:28.000000000 -0800 +++ pygpgme-0.3/tests/test_encrypt_decrypt.py 2016-02-05 10:21:58.966685384 -0800 @@ -125,7 +125,7 @@ ctx.decrypt(ciphertext, plaintext) self.assertEqual(plaintext.getvalue(), b'Hello World\n') - def test_encrypt_symmetric(self): + def skip_test_encrypt_symmetric(self): plaintext = BytesIO(b'Hello World\n') ciphertext = BytesIO() def passphrase(uid_hint, passphrase_info, prev_was_bad, fd): --- pygpgme-0.3/tests/test_passphrase.py 2012-02-28 19:04:17.000000000 -0800 +++ pygpgme-0.3/tests/test_passphrase.py 2016-02-05 10:21:47.990630956 -0800 @@ -30,7 +30,7 @@ import_keys = ['passphrase.pub', 'passphrase.sec'] - def test_sign_without_passphrase_cb(self): + def skip_test_sign_without_passphrase_cb(self): ctx = gpgme.Context() key = ctx.get_key('EFB052B4230BBBC51914BCBB54DCBBC8DBFB9EB3') ctx.signers = [key] @@ -51,7 +51,7 @@ self.prev_was_bad = prev_was_bad os.write(fd, b'test\n') - def test_sign_with_passphrase_cb(self): + def skip_test_sign_with_passphrase_cb(self): ctx = gpgme.Context() key = ctx.get_key('EFB052B4230BBBC51914BCBB54DCBBC8DBFB9EB3') ctx.signers = [key] elect name='qt'>
path: root/NEWS
AgeCommit message (Expand)Author
2023-03-28NEWS: Mention new rpm format....* NEWS (Package management): Mention new rpm format. Maxim Cournoyer
2022-12-18Update NEWS.Ludovic Courtès
2022-12-17Update NEWS.Marius Bakke
2022-12-02Update NEWS.Ludovic Courtès
2022-11-23NEWS: Update it....* NEWS: Shepherd is already at 0.9.3 now. Jonathan Brielmaier
2022-11-16Update NEWS.Maxim Cournoyer
2022-10-13NEWS: Update it....* NEWS: Add an entry about 'guix shell' --emulate-fhs option. Mathieu Othacehe
2022-10-07Update NEWS....* NEWS: Add new entry for installation script improvements. Maxim Cournoyer
2022-09-28Update NEWS....* NEWS: Add new services for the 1.4.0. Mathieu Othacehe
2022-09-26NEWS: Update it....* NEWS: Add an entry about WSL images. Mathieu Othacehe
2022-09-24Update NEWS.Ludovic Courtès
2022-09-23Update NEWS.Maxim Cournoyer
2022-09-19Update NEWS....* NEWS: Mention Shepherd 0.9.2 upgrade. Mathieu Othacehe
2022-09-16Update NEWS....Entries extracted from: git log 3eadcdc63..version-1.4.0 * NEWS: Update entries for v1.4.0 Mathieu Othacehe
2022-09-15Update NEWS....This covers the commits made between v1.3.0..3eadcdc6^. * NEWS: New entries for the 1.4.0 upcoming release. Maxim Cournoyer
2022-09-14Update NEWS....These news were extracted from the output of: git log --reverse v1.3.0..03eb0b1be2cfedd0d9a66fef0edc53a17f7653a5. * NEWS: Update entries for v1.4.0. Maxim Cournoyer
2021-11-23Update NEWS.Ludovic Courtès