Update the wscript to work with waf-1.8.8. Based on:
http://cgit.freedesktop.org/pycairo/commit/?id=c57cd129407c904f8c2f752a59d0183df7b01a5e
--- pycairo-1.10.0.orig/wscript 2011-04-18 15:42:29.000000000 +0800
+++ pycairo-1.10.0/wscript 2015-04-20 13:01:45.383756898 +0800
@@ -13,18 +13,18 @@
def options(ctx):
print(' %s/options()' %d)
- ctx.tool_options('gnu_dirs')
- ctx.tool_options('compiler_cc')
- ctx.tool_options('python') # options for disabling pyc or pyo compilation
+ ctx.load('gnu_dirs')
+ ctx.load('compiler_c')
+ ctx.load('python') # options for disabling pyc or pyo compilation
def configure(ctx):
print(' %s/configure()' %d)
env = ctx.env
- ctx.check_tool('gnu_dirs')
- ctx.check_tool('compiler_cc')
- ctx.check_tool('python')
+ ctx.load('gnu_dirs')
+ ctx.load('compiler_c')
+ ctx.load('python')
ctx.check_python_version((3,1,0))
ctx.check_python_headers()
ctx.check_cfg(package='cairo', atleast_version=cairo_version_required,
/td>
Age | Commit message (Expand) | Author |
2021-12-17 | gnu: Remove unreferenced nss/fixed....* gnu/packages/nss.scm (nss/fixed): Remove variable.
* gnu/packages/patches/nss-CVE-2021-43527.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
| Tobias Geerinckx-Rice |
2021-12-16 | gnu: nss-certs: Avoid top-level reference to NSS....This is the only hammer I know for dealing with module cycles and
effectively fixes, for example, ‘guix show nss’ today.
It's also a very poor solution.
* gnu/packages/certs.scm (nss-certs)[version, source]: Copy verbatim
from the nss package rather than referring to it at the top level.
Reported by several users of #guix.
| Tobias Geerinckx-Rice |
2021-12-13 | gnu: Simplify package inputs....This commit was obtained by running:
./pre-inst-env guix style
without any additional argument.
| Ludovic Courtès |
2021-12-05 | Merge remote-tracking branch 'origin/master' into core-updates-frozen | Ricardo Wurmus |
2021-12-03 | gnu: nss: Fix CVE-2021-43527 via graft....* gnu/packages/patches/nss-CVE-2021-43527.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/nss.scm (nss/fixed): New variable
(nss)[replacement]: New field.
| Mark H Weaver |
2021-12-01 | gnu: Add nspr@4.32....Required for icecat/icedove 91.
* gnu/packages/nss.scm (nspr-4.32): New variable.
| Jonathan Brielmaier |