Gracefully deal with 'stty size' failures. Submitted upstream. --- pybugz-0.6.11/bugz.py 2006-09-02 14:35:37.000000000 +0200 +++ pybugz-0.6.11/bugz.py 2014-05-05 15:17:03.000000000 +0200 @@ -288,7 +288,12 @@ def get_cols(): stty = which('stty') if stty: row_cols = commands.getoutput("%s size" % stty) - rows, cols = map(int, row_cols.split()) + try: + rows, cols = map(int, row_cols.split()) + except: + # In some cases 'stty size' will just fail with + # "Inappropriate ioctl for device". + cols = DEFAULT_NUM_COLS return cols else: return DEFAULT_NUM_COLS d910e377048'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/nix/libstore
AgeCommit message (Expand)Author
2022-05-29daemon: Clarify ‘--check’ error when outputs are missing....Tobias Geerinckx-Rice
2022-05-18daemon: runChild() is forbidden to talk during environment set up...yarl-baudig@mailoo.org
2022-01-18daemon: Always default to gzip for log compression....Ludovic Courtès
2021-11-27daemon: Print the line whence we expect an integer....Tobias Geerinckx-Rice
2021-11-25daemon: Read substitute nar size as 'unsigned long long'....Ludovic Courtès
2021-11-25daemon: Read unsigned nar size and download size from substituter....Ludovic Courtès
2021-11-16daemon: Do not deduplicate files smaller than 8 KiB....Ludovic Courtès
2021-04-09daemon: 'guix substitute' replies on FD 4....Ludovic Courtès
2021-03-18daemon: Prevent privilege escalation with '--keep-failed' [security]....Ludovic Courtès