Gracefully deal with 'stty size' failures. Submitted upstream. --- pybugz-0.6.11/bugz.py 2006-09-02 14:35:37.000000000 +0200 +++ pybugz-0.6.11/bugz.py 2014-05-05 15:17:03.000000000 +0200 @@ -288,7 +288,12 @@ def get_cols(): stty = which('stty') if stty: row_cols = commands.getoutput("%s size" % stty) - rows, cols = map(int, row_cols.split()) + try: + rows, cols = map(int, row_cols.split()) + except: + # In some cases 'stty size' will just fail with + # "Inappropriate ioctl for device". + cols = DEFAULT_NUM_COLS return cols else: return DEFAULT_NUM_COLS d5a882b3a70223df51c7317b3737d'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/sync.scm
AgeCommit message (Expand)Author
2022-11-15gnu: Add onedrive....Efraim Flashner
2022-07-31gnu: qttools: Rename to qttools-5....Maxim Cournoyer
2022-07-31gnu: qtwebengine: Rename to qtwebengine-5....Maxim Cournoyer
2022-07-31gnu: qtwebchannel: Rename to qtwebchannel-5....Maxim Cournoyer
2022-07-31gnu: qtwebsockets: Rename to qtwebsockets-5....Maxim Cournoyer
2022-07-31gnu: qtquickcontrols2: Rename to qtquickcontrols2-5....Maxim Cournoyer
2022-07-31gnu: qtdeclarative: Rename to qtdeclarative-5....Maxim Cournoyer
2022-07-31gnu: qtsvg: Rename variable to qtsvg-5....Maxim Cournoyer
2022-05-30gnu: casync: Update to 99559cd1....Greg Hogan