Gracefully deal with 'stty size' failures.
Submitted upstream.
--- pybugz-0.6.11/bugz.py 2006-09-02 14:35:37.000000000 +0200
+++ pybugz-0.6.11/bugz.py 2014-05-05 15:17:03.000000000 +0200
@@ -288,7 +288,12 @@ def get_cols():
stty = which('stty')
if stty:
row_cols = commands.getoutput("%s size" % stty)
- rows, cols = map(int, row_cols.split())
+ try:
+ rows, cols = map(int, row_cols.split())
+ except:
+ # In some cases 'stty size' will just fail with
+ # "Inappropriate ioctl for device".
+ cols = DEFAULT_NUM_COLS
return cols
else:
return DEFAULT_NUM_COLS
'f63f524053a9a8503bf98532b6b3d91b17c1d7c0'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2019-06-05 | etc: Fix GUIX_LOCPATH quoting in 'guix-publish.service' file....This is a followup to 579d17b70dac067f8194ede46513400b91ac136a.
* etc/guix-publish.service.in (Environment): Move GUIX_LOCPATH inside
the quotes.
| Jack Hill |
2019-05-13 | Set 'LC_ALL=en_US.utf8' in systemd '.service' files....Fixes <https://bugs.gnu.org/35671>.
* etc/guix-daemon.service.in (Environment): Quote the 'GUIX_LOCPATH'
value; add 'LC_ALL'.
* etc/guix-publish.service.in (Environment): Likewise.
| Ludovic Courtès |
2018-11-23 | build: Binary tarball now populates the "current-guix" profile....* Makefile.am (guix-binary.%.tar.xz): Pass
'--profile-name=current-guix'. Remove glibc and glibc-utf8-locales.
* doc/guix.texi (Binary Installation): Update accordingly.
* etc/guix-install.sh
* etc/guix-install.sh (sys_create_store, sys_enable_guix_daemon)
(sys_authorize_build_farms): Likewise.
* etc/guix-publish.conf.in, etc/guix-publish.service.in,
etc/guix-daemon.conf.in, etc/guix-daemon.service.in: Update file names
accordingly.
| Ludovic Courtès |