Gracefully deal with 'stty size' failures.
Submitted upstream.
--- pybugz-0.6.11/bugz.py 2006-09-02 14:35:37.000000000 +0200
+++ pybugz-0.6.11/bugz.py 2014-05-05 15:17:03.000000000 +0200
@@ -288,7 +288,12 @@ def get_cols():
stty = which('stty')
if stty:
row_cols = commands.getoutput("%s size" % stty)
- rows, cols = map(int, row_cols.split())
+ try:
+ rows, cols = map(int, row_cols.split())
+ except:
+ # In some cases 'stty size' will just fail with
+ # "Inappropriate ioctl for device".
+ cols = DEFAULT_NUM_COLS
return cols
else:
return DEFAULT_NUM_COLS
put type='hidden' name='id' value='162048be3b838e221e5256b0f670ac6f884f607a'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-02-14 | gnu: mumps: Change "5.1.2" to "5.2.1" in library file names....* gnu/packages/patches/mumps-shared-libseq.patch,
gnu/packages/patches/mumps-shared-mumps.patch,
gnu/packages/patches/mumps-shared-pord.patch: Replace "5.1.2" with
"5.2.1" in file names.
Co-authored-by: Ludovic Courtès <ludo@gnu.org>
| Maurice Bremond |
2019-10-14 | gnu: mumps: Build and install shared libraries....* gnu/packages/patches/mumps-shared-libseq.patch,
gnu/packages/patches/mumps-shared-mumps.patch,
gnu/packages/patches/mumps-shared-pord.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/maths.scm (mumps)[source](patches): Add them.
[arguments]: In 'configure' phase, adjust "Makefile.inc" for shared
library support. In 'install' phase, install libmpiseq.so when it
exists.
Co-authored-by: Ludovic Courtès <ludovic.courtes@inria.fr>
| Maurice Brémond |