Gracefully deal with 'stty size' failures. Submitted upstream. --- pybugz-0.6.11/bugz.py 2006-09-02 14:35:37.000000000 +0200 +++ pybugz-0.6.11/bugz.py 2014-05-05 15:17:03.000000000 +0200 @@ -288,7 +288,12 @@ def get_cols(): stty = which('stty') if stty: row_cols = commands.getoutput("%s size" % stty) - rows, cols = map(int, row_cols.split()) + try: + rows, cols = map(int, row_cols.split()) + except: + # In some cases 'stty size' will just fail with + # "Inappropriate ioctl for device". + cols = DEFAULT_NUM_COLS return cols else: return DEFAULT_NUM_COLS 056bca5a0ac1b1d4b9a2522'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/tests/base.scm
AgeCommit message (Expand)Author
2022-11-18services: Add Shepherd 'configuration' action to various services....Ludovic Courtès
2022-11-17tests: root-unmount: Wait for the first QEMU process to finish....Ludovic Courtès
2022-10-07marionette: Make marionette-screen-text private....Maxim Cournoyer
2022-08-28build: marionette: Add support for Tesseract OCR....Maxim Cournoyer
2022-07-01image: Add default value for partition initializer....Ludovic Courtès
2022-07-01services: root-file-system: Cleanly unmount upon shutdown....Ludovic Courtès
2022-03-19tests: install: Adjust the timeouts on two failing tests....Maxim Cournoyer