https://sigrok.org/gitweb/?p=pulseview.git;a=patch;h=ae726b70a7ada9a4be5808e00f0c951318479684 From ae726b70a7ada9a4be5808e00f0c951318479684 Mon Sep 17 00:00:00 2001 From: Valentin Ochs Date: Sat, 20 Jun 2020 16:01:27 +0200 Subject: [PATCH] Replace obsolete/deprecated Qt methods --- pv/subwindows/decoder_selector/subwindow.cpp | 2 +- pv/util.cpp | 21 ++++++++++++++++++-- pv/util.hpp | 10 ++++++++++ pv/views/trace/decodetrace.cpp | 3 ++- pv/views/trace/ruler.cpp | 2 +- pv/widgets/timestampspinbox.cpp | 2 +- 6 files changed, 34 insertions(+), 6 deletions(-) diff --git a/pv/subwindows/decoder_selector/subwindow.cpp b/pv/subwindows/decoder_selector/subwindow.cpp index 94ed6f4b..2c65dcf2 100644 --- a/pv/subwindows/decoder_selector/subwindow.cpp +++ b/pv/subwindows/decoder_selector/subwindow.cpp @@ -185,7 +185,7 @@ QToolBar* SubWindow::create_toolbar(QWidget *parent) const int SubWindow::minimum_width() const { QFontMetrics m(info_label_body_->font()); - const int label_width = m.width(QString(tr(initial_notice))); + const int label_width = util::text_width(m, tr(initial_notice)); return label_width + min_width_margin; } diff --git a/pv/util.cpp b/pv/util.cpp index 897254e1..dfb8c72b 100644 --- a/pv/util.cpp +++ b/pv/util.cpp @@ -143,7 +143,7 @@ QString format_time_si(const Timestamp& v, SIPrefix prefix, QString s; QTextStream ts(&s); if (sign && !v.is_zero()) - ts << forcesign; + ts.setNumberFlags(ts.numberFlags() | QTextStream::ForceSign); ts << qSetRealNumberPrecision(precision) << (v * multiplier); ts << ' ' << prefix << unit; @@ -169,7 +169,7 @@ QString format_value_si(double v, SIPrefix prefix, unsigned precision, QString s; QTextStream ts(&s); if (sign && (v != 0)) - ts << forcesign; + ts.setNumberFlags(ts.numberFlags() | QText
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2022 Gabriel Wicki <gabriel@erlikon.ch>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu system images pine64)
  #:use-module (gnu bootloader)
  #:use-module (gnu bootloader u-boot)
  #:use-module (gnu image)
  #:use-module (gnu packages linux)
  #:use-module (gnu packages certs)
  #:use-module (guix platforms arm)
  #:use-module (gnu services)
  #:use-module (gnu services base)
  #:use-module (gnu services networking)
  #:use-module (gnu system)
  #:use-module (gnu system file-systems)
  #:use-module (gnu system image)
  #:use-module (srfi srfi-26)
  #:export (pine64-barebones-os
            pine64-image-type
            pine64-barebones-raw-image))

(define pine64-barebones-os
  (operating-system
    (host-name "vignemale")
    (timezone "Europe/Paris")
    (locale "en_US.utf8")
    (bootloader (bootloader-configuration
                 (bootloader u-boot-pine64-lts-bootloader)
                 (targets '("/dev/vda"))))
    (initrd-modules '())
    (kernel linux-libre-arm64-generic)
    (file-systems (cons (file-system
                          (device (file-system-label "my-root"))
                          (mount-point "/")
                          (type "ext4"))
                        %base-file-systems))
    (services (cons*
               (service agetty-service-type
                        (agetty-configuration
                         (extra-options '("-L")) ; no carrier detect
                         (baud-rate "115200")
                         (term "vt100")
                         (tty "ttyS0")))
               (service dhcp-client-service-type)
               (service ntp-service-type)
               %base-services))))

(define pine64-image-type
  (image-type
   (name 'pine64-raw)
   (constructor (lambda (os)
                  (image
                   (inherit (raw-with-offset-disk-image))
                   (operating-system os)
                   (platform aarch64-linux))))))

(define pine64-barebones-raw-image
  (image
   (inherit
    (os+platform->image pine64-barebones-os aarch64-linux
                        #:type pine64-image-type))
   (name 'pine64-barebones-raw-image)))

;; Return the default image.
pine64-barebones-raw-image