Avoid signed overflow during mult-s16-test which intermittently failed. Patch by Mark H Weaver . --- pulseaudio-5.0/src/tests/mult-s16-test.c.orig 2014-01-23 13:57:55.000000000 -0500 +++ pulseaudio-5.0/src/tests/mult-s16-test.c 2014-10-24 03:13:46.464661815 -0400 @@ -55,7 +55,7 @@ START_TEST (mult_s16_test) { int16_t samples[SAMPLES]; int32_t volumes[SAMPLES]; - int32_t sum1 = 0, sum2 = 0; + uint32_t sum1 = 0, sum2 = 0; int i; pa_random(samples, sizeof(samples)); ='main'>index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/file-systems.scm
AgeCommit message (Collapse)Author
2023-09-17gnu: file-systems: Add variable %base-live-file-systems.Nicolas Graves
* gnu/system/file-systems.scm (%base-live-file-systems): New variable. * gnu/system/install.scm (installation-os): Use %base-live-file-systems. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2023-08-08file-systems: Use cgroups v2.Sam Lockart
cgroup v2 is the next generation of the control groups API. This patch replaces the cgroup v1 file systems with the unified cgroup v2 file system. cgroup v2 allows for things like containerd/podman to run rootless containers and opens guix system up to running things like Kubernetes. Thanks to Hilton Chain <hako@ultrarare.space> for suggesting the Docker service change. * gnu/system/file-systems.scm (%control-groups): Change to a single "cgroup2" mount point. * gnu/services/docker.scm (docker-shepherd-service): Trim 'requirement' field accordingly. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
2023-03-05file-systems: Remove deprecated 'title' field helper procedures.Bruno Victal
* gnu/system/file-systems.scm (<file-system>): Change constructor name to 'file-system'. (report-deprecation, device-expression, process-file-system-declaration, file-system): Remove macros. (file-system-title): Remove procedure. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2023-02-26file-systems: Validate 'no-diratime flag.Tobias Geerinckx-Rice
This follows up on commit c0773455397746b10194bc14c7cef144f4095b65, and adds a comment to avoid this in future. * gnu/system/file-systems.scm (invalid-file-system-flags): Add 'no-diratime to the list of KNOWN-FLAGS.