Rename getline() to procmail_getline() to avoid namespace clash with
POSIX getline(). Fixes FTBFS.
Copied from Debian:
http://sources.debian.net/src/procmail/3.22-24/debian/patches/24/
References:
http://bugs.debian.org/549426
--- a/src/fields.c
+++ b/src/fields.c
@@ -110,16 +110,16 @@
/* try and append one valid field to rdheader from stdin */
int readhead P((void))
{ int idlen;
- getline();
+ procmail_getline();
if((idlen=breakfield(buf,buffilled))<=0) /* not the start of a valid field */
return 0;
if(idlen==STRLEN(FROM)&&eqFrom_(buf)) /* it's a From_ line */
{ if(rdheader)
return 0; /* the From_ line was a fake! */
- for(;buflast=='>';getline()); /* gather continued >From_ lines */
+ for(;buflast=='>';procmail_getline()); /* gather continued >From_ lines */
}
else
- for(;;getline()) /* get the rest of the continued field */
+ for(;;procmail_getline()) /* get the rest of the continued field */
{ switch(buflast) /* will this line be continued? */
{ case ' ':case '\t': /* yep, it sure is */
continue;
--- a/src/formail.c
+++ b/src/formail.c
@@ -819,7 +819,7 @@
{ if(split) /* gobble up the next start separator */
{ buffilled=0;
#ifdef sMAILBOX_SEPARATOR
- getline();buffilled=0; /* but only if it's defined */
+ procmail_getline();buffilled=0; /* but only if it's defined */
#endif
if(buflast!=EOF) /* if any */
goto splitit;
--- a/src/formisc.c
+++ b/src/formisc.c
@@ -115,7 +115,7 @@
buf[buffilled++]=c;
}
-int getline P((void)) /* read a newline-terminated line */
+int procmail_getline P((void)) /* read a newline-terminated line */
{ if(buflast==EOF) /* at the end of our Latin already? */
{ loadchar('\n'); /* fake empty line */
return EOF; /* spread the word */
--- a/src/formisc.h
+++ b/src/formisc.h
@@ -17,4 +17,4 @@
char*
skipwords P((char*start));
int
- getline P((void));
+ procmail_getline P((void));
849c7df18f9f63caf'>root/gnu/packages/ntp.scm
Age | Commit message (Expand) | Author |
2021-05-22 | gnu: ntp: Prepare for GCC 10....* gnu/packages/ntp.scm (ntp)[source](patches): New field.
| Marius Bakke |
2021-05-13 | gnu: chrony: Update to 4.1....* gnu/packages/ntp.scm (chrony): Update to 4.1.
| Tobias Geerinckx-Rice |
2020-12-13 | gnu: openntpd: Update to 6.8p1....* gnu/packages/ntp.scm (openntpd): Update to 6.8p1.
| Tobias Geerinckx-Rice |
2020-10-13 | gnu: libcap: Make 'libcap/next' the default libcap....* gnu/packages/avahi.scm (avahi)[inputs]: Refer to LIBCAP-2.31 instead of LIBCAP.
* gnu/packages/base.scm (coreutils)[inputs]: Likewise.
* gnu/packages/linux.scm (libcap): Rename to ...
(libcap-2.31): ... this.
(libcap/next): Rename to ...
(libcap): ... this.
(libcap/next): Define as deprecated alias for LIBCAP.
(fakeroot)[inputs]: Change from LIBCAP/NEXT to LIBCAP.
* gnu/packages/ntp.scm (chrony, ntp)[inputs]: Likewise.
| Marius Bakke |
2020-10-08 | gnu: chrony: Support Network Time Security (NTS)....* gnu/packages/ntp.scm (chrony)[inputs]: Add gnutls.
| Tobias Geerinckx-Rice |
2020-10-08 | gnu: chrony: Update to 4.0....* gnu/packages/ntp.scm (chrony): Update to 4.0.
| Tobias Geerinckx-Rice |