Rename getline() to procmail_getline() to avoid namespace clash with
POSIX getline(). Fixes FTBFS.
Copied from Debian:
http://sources.debian.net/src/procmail/3.22-24/debian/patches/24/
References:
http://bugs.debian.org/549426
--- a/src/fields.c
+++ b/src/fields.c
@@ -110,16 +110,16 @@
/* try and append one valid field to rdheader from stdin */
int readhead P((void))
{ int idlen;
- getline();
+ procmail_getline();
if((idlen=breakfield(buf,buffilled))<=0) /* not the start of a valid field */
return 0;
if(idlen==STRLEN(FROM)&&eqFrom_(buf)) /* it's a From_ line */
{ if(rdheader)
return 0; /* the From_ line was a fake! */
- for(;buflast=='>';getline()); /* gather continued >From_ lines */
+ for(;buflast=='>';procmail_getline()); /* gather continued >From_ lines */
}
else
- for(;;getline()) /* get the rest of the continued field */
+ for(;;procmail_getline()) /* get the rest of the continued field */
{ switch(buflast) /* will this line be continued? */
{ case ' ':case '\t': /* yep, it sure is */
continue;
--- a/src/formail.c
+++ b/src/formail.c
@@ -819,7 +819,7 @@
{ if(split) /* gobble up the next start separator */
{ buffilled=0;
#ifdef sMAILBOX_SEPARATOR
- getline();buffilled=0; /* but only if it's defined */
+ procmail_getline();buffilled=0; /* but only if it's defined */
#endif
if(buflast!=EOF) /* if any */
goto splitit;
--- a/src/formisc.c
+++ b/src/formisc.c
@@ -115,7 +115,7 @@
buf[buffilled++]=c;
}
-int getline P((void)) /* read a newline-terminated line */
+int procmail_getline P((void)) /* read a newline-terminated line */
{ if(buflast==EOF) /* at the end of our Latin already? */
{ loadchar('\n'); /* fake empty line */
return EOF; /* spread the word */
--- a/src/formisc.h
+++ b/src/formisc.h
@@ -17,4 +17,4 @@
char*
skipwords P((char*start));
int
- getline P((void));
+ procmail_getline P((void));
ass='path'>path: root/gnu/packages/kde-internet.scm
Age | Commit message (Expand) | Author |
2020-02-22 | gnu: choqok: Update to 1.7.0....* gnu/packages/kde-internet.scm (choqok): Update to 1.7.0.
(inputs): Add purpose, qtnetworkauth.
(source): Don't apply patch.
* gnu/packages/patches/choqok-Fix-building-under-Qt-5.13.patch: Remove
(no longer needed).
| Jakub Kądziołka |
2020-02-13 | gnu: choqok: Fix typo in description....This fixes ‘guix show choqok’ and friends.
* gnu/packages/kde-internet.scm (choqok)[description]: Escape ‘@’.
| Tobias Geerinckx-Rice |
2020-02-03 | gnu: Add libgravatar....* gnu/packages/kde-internet.scm (libgravatar): New variable.
| Hartmut Goebel |
2020-02-03 | gnu: libktorrent: Base source-code URL on version of ktorrent....* gnu/packages/kde-internet.scm (libktorrent)[source]: Base
path in URL on version of ktorrent.
| Hartmut Goebel |
2020-02-03 | gnu: Add ktorrent....* gnu/packages/kde-internet.scm (ktorrent): New variable.
| Hartmut Goebel |
2020-02-03 | gnu: Add libktorrent....* gnu/packages/kde-internet.scm (libktorrent): New variable.
| Hartmut Goebel |
2020-02-03 | gnu: Add krdc....VNC support is yet missing since I did not find the required VNC packages.
* gnu/packages/kde-internet.scm (krdc): New variable.
| Hartmut Goebel |
2020-02-03 | gnu: Add kopete....Not all optional packages are enabled yet.
* gnu/packages/kde-internet.scm (kopete): New variable.
| Hartmut Goebel |
2020-02-03 | gnu: Add konversation....* gnu/packages/kde-internet.scm (konversation): New variable.
* gnu/packages/patches/konversation-Fix-build-with-Qt-5.11.patch: New file.
* gnu/lokal.mk: Add it.
| Hartmut Goebel |
2020-02-03 | gnu: Add kget....* gnu/packages/kde-internet.scm (kget): New variable.
| Hartmut Goebel |
2020-02-03 | gnu: Add choqok....* gnu/packages/kde-internet.scm: New file.
* gnu/packages/patches/choqok-Fix-building-under-Qt-5.13.patch: New file.
* gnu/lokal.mk: Add them.
| Hartmut Goebel |