Rename getline() to procmail_getline() to avoid namespace clash with
POSIX getline(). Fixes FTBFS.
Copied from Debian:
http://sources.debian.net/src/procmail/3.22-24/debian/patches/24/
References:
http://bugs.debian.org/549426
--- a/src/fields.c
+++ b/src/fields.c
@@ -110,16 +110,16 @@
/* try and append one valid field to rdheader from stdin */
int readhead P((void))
{ int idlen;
- getline();
+ procmail_getline();
if((idlen=breakfield(buf,buffilled))<=0) /* not the start of a valid field */
return 0;
if(idlen==STRLEN(FROM)&&eqFrom_(buf)) /* it's a From_ line */
{ if(rdheader)
return 0; /* the From_ line was a fake! */
- for(;buflast=='>';getline()); /* gather continued >From_ lines */
+ for(;buflast=='>';procmail_getline()); /* gather continued >From_ lines */
}
else
- for(;;getline()) /* get the rest of the continued field */
+ for(;;procmail_getline()) /* get the rest of the continued field */
{ switch(buflast) /* will this line be continued? */
{ case ' ':case '\t': /* yep, it sure is */
continue;
--- a/src/formail.c
+++ b/src/formail.c
@@ -819,7 +819,7 @@
{ if(split) /* gobble up the next start separator */
{ buffilled=0;
#ifdef sMAILBOX_SEPARATOR
- getline();buffilled=0; /* but only if it's defined */
+ procmail_getline();buffilled=0; /* but only if it's defined */
#endif
if(buflast!=EOF) /* if any */
goto splitit;
--- a/src/formisc.c
+++ b/src/formisc.c
@@ -115,7 +115,7 @@
buf[buffilled++]=c;
}
-int getline P((void)) /* read a newline-terminated line */
+int procmail_getline P((void)) /* read a newline-terminated line */
{ if(buflast==EOF) /* at the end of our Latin already? */
{ loadchar('\n'); /* fake empty line */
return EOF; /* spread the word */
--- a/src/formisc.h
+++ b/src/formisc.h
@@ -17,4 +17,4 @@
char*
skipwords P((char*start));
int
- getline P((void));
+ procmail_getline P((void));
8b8f7cb0512495961935dca9fe5ef62'>.gitignore
Age | Commit message (Expand) | Author |
2023-10-22 | teams: Adjust shebang to use 'guix repl'....This ensures the correct Guix dependencies are always available for the
script.
* etc/teams.scm.in: Rename to...
* etc/teams.scm: ... this. Adjust shebang.
* .gitignore: No longer ignore it.
* configure.ac: Do not process it with AC_CONFIG_FILES.
Reported-by: Clément Lassieur <clement@lassieur.org>
Fixes: https://issues.guix.gnu.org/66605
Change-Id: I7a01750c6c5f0696b6c36b1e6caa9389d9e6822c
| Maxim Cournoyer |
2023-04-24 | Add mumi config....* .mumi/config: New file.
* .gitignore: Add .mumi/current-issue.
| Arun Isaac |
2022-07-03 | etc: Add teams.scm....* etc/teams.scm.in: New file.
* configure.ac: Generate executable.
* .gitignore: Ignore generated file.
| Ricardo Wurmus |
2022-06-05 | gitignore: Add .DS_Store....Ignore MacOS specific file: https://en.wikipedia.org/wiki/.DS_Store
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Pavel Shlyak |
2021-10-16 | .gitignore: Ignore more autotools directories....* .gitignore: Add pattern to ignore ".am[0-9]*/".
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Sarah Morgensen |
2021-10-16 | .gitignore: Ignore more temporary test directories....* .gitignore: Add pattern to ignore "/t-*/".
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
| Sarah Morgensen |
2021-09-20 | etc: Add systemd files for running ‘guix gc’ periodically...* etc/guix-gc.service.in: New file.
* etc/guix-gc.timer: Likewise.
* .gitignore: Ignore generated ‘guix-gc.service’.
* nix/local.mk (nodist_systemdservice_DATA): Add ‘guix-gc.service’ and
‘guix-gc.timer’.
(EXTRA_DIST): Add ‘guix-gc.service.in’ and ‘guix-gc.timer’.
* doc/guix.texi (Binary Installation): Mention the new systemd files.
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Thiago Jung Bauermann |