Fix CVE-2017-16844: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16844 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=876511 Patch copied from Debian procmail package 3.22-26: http://http.debian.net/debian/pool/main/p/procmail/procmail_3.22-26.debian.tar.xz From: Santiago Vila Subject: Fix heap-based buffer overflow in loadbuf() Bug-Debian: http://bugs.debian.org/876511 X-Debian-version: 3.22-26 --- a/src/formisc.c +++ b/src/formisc.c @@ -103,7 +103,7 @@ } /* append to buf */ void loadbuf(text,len)const char*const text;const size_t len; -{ if(buffilled+len>buflen) /* buf can't hold the text */ +{ while(buffilled+len>buflen) /* buf can't hold the text */ buf=realloc(buf,buflen+=Bsize); tmemmove(buf+buffilled,text,len);buffilled+=len; } n> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/local.mk
AgeCommit message (Expand)Author
2019-04-10gnu: kodi: Allow connecting to HTTPS sources....Carlo Zancanaro
2019-04-08gnu: libopenshot: Update to 0.2.3....Efraim Flashner
2019-04-07gnu: lcms: Fix CVE-2018-16435....Efraim Flashner
2019-04-05gnu: Add emacs-undohist-el....Brian Leung
2019-04-05gnu: Add localed, extracted from systemd....Ludovic Courtès
2019-04-05gnu: flac: Fix CVE-2017-6888....Efraim Flashner
2019-04-05gnu: ledger: Update to 3.1.3....Tobias Geerinckx-Rice
2019-04-04gnu: Move nss & co. to nss.scm....Ludovic Courtès
2019-04-04gnu: Add (gnu packages haskell-apps)....Ludovic Courtès
2019-04-04build: Always ship the (gnu installer …) modules....Ludovic Courtès
2019-04-03gnu: ntfs-3g: Fix CVE-2019-9755....Leo Famulari
2019-04-03gnu: Add configuration for depthcharge bootloader....Timothy Sample
2019-03-31gnu: emacs-zones: silence byte-compiler....Brian Leung