Fix CVE-2017-16844: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16844 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=876511 Patch copied from Debian procmail package 3.22-26: http://http.debian.net/debian/pool/main/p/procmail/procmail_3.22-26.debian.tar.xz From: Santiago Vila Subject: Fix heap-based buffer overflow in loadbuf() Bug-Debian: http://bugs.debian.org/876511 X-Debian-version: 3.22-26 --- a/src/formisc.c +++ b/src/formisc.c @@ -103,7 +103,7 @@ } /* append to buf */ void loadbuf(text,len)const char*const text;const size_t len; -{ if(buffilled+len>buflen) /* buf can't hold the text */ +{ while(buffilled+len>buflen) /* buf can't hold the text */ buf=realloc(buf,buflen+=Bsize); tmemmove(buf+buffilled,text,len);buffilled+=len; } scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/mc.scm
AgeCommit message (Expand)Author
2019-06-25gnu: mc: Update to 4.8.23....Tobias Geerinckx-Rice
2019-03-18Correct name and email address for ng0....ng0
2019-02-27gnu: mc: Update to 4.8.22....Tobias Geerinckx-Rice
2018-03-20Correct name and Email for ng0....ng0
2018-02-08gnu: mc: Substitute more FHS file names....Tobias Geerinckx-Rice
2018-01-16gnu: mc: Update to 4.8.20....Tobias Geerinckx-Rice
2018-01-16gnu: mc: Use HTTPS for home page....Tobias Geerinckx-Rice
2017-11-19Update email address for ng0.ng0