Fix CVE-2017-16844: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16844 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=876511 Patch copied from Debian procmail package 3.22-26: http://http.debian.net/debian/pool/main/p/procmail/procmail_3.22-26.debian.tar.xz From: Santiago Vila Subject: Fix heap-based buffer overflow in loadbuf() Bug-Debian: http://bugs.debian.org/876511 X-Debian-version: 3.22-26 --- a/src/formisc.c +++ b/src/formisc.c @@ -103,7 +103,7 @@ } /* append to buf */ void loadbuf(text,len)const char*const text;const size_t len; -{ if(buffilled+len>buflen) /* buf can't hold the text */ +{ while(buffilled+len>buflen) /* buf can't hold the text */ buf=realloc(buf,buflen+=Bsize); tmemmove(buf+buffilled,text,len);buffilled+=len; } zko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xfig.scm
AgeCommit message (Expand)Author
2017-01-13gnu: xfig: Correct typographic error....John Darrington
2017-01-12gnu: xfig: Remove wrapper and clean up implementation....John Darrington
2017-01-12gnu: xfig: Use modify-phases....John Darrington
2014-11-24gnu: xfig: Add 'wrap-xfig phase....Federico Beffa
2014-10-13gnu: xfig, transfig: Patch compiler flags for mips and i686....Eric Bavier
2014-10-11gnu: Add transfig....Eric Bavier
2014-10-11gnu: Add xfig....Eric Bavier