Fix CVE-2017-16844: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-16844 https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=876511 Patch copied from Debian procmail package 3.22-26: http://http.debian.net/debian/pool/main/p/procmail/procmail_3.22-26.debian.tar.xz From: Santiago Vila Subject: Fix heap-based buffer overflow in loadbuf() Bug-Debian: http://bugs.debian.org/876511 X-Debian-version: 3.22-26 --- a/src/formisc.c +++ b/src/formisc.c @@ -103,7 +103,7 @@ } /* append to buf */ void loadbuf(text,len)const char*const text;const size_t len; -{ if(buffilled+len>buflen) /* buf can't hold the text */ +{ while(buffilled+len>buflen) /* buf can't hold the text */ buf=realloc(buf,buflen+=Bsize); tmemmove(buf+buffilled,text,len);buffilled+=len; } oszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/avahi.scm
AgeCommit message (Expand)Author
2023-05-29gnu: avahi: Support for cross-building and the Hurd....Janneke Nieuwenhuizen
2022-01-10gnu: avahi: Make all arguments unconditional....Maxim Cournoyer
2021-09-20gnu: avahi: Use the cross-compiled bash....Maxime Devos
2021-09-20gnu: avahi: Find 'TARGET-pkg-config' when cross-compiling....Maxime Devos
2021-05-09gnu: libcap: Update to 2.49....Marius Bakke
2020-10-13gnu: libcap: Make 'libcap/next' the default libcap....Marius Bakke
2020-03-18gnu: avahi: Update to 0.8....Marius Bakke
2020-03-18gnu: avahi: Do not build the static libraries....Marius Bakke
2020-01-21Merge branch 'staging' into core-updatesMarius Bakke
2020-01-19gnu: Use HTTPS for avahi.org everywhere....Tobias Geerinckx-Rice