This relaxes the comparison threshold between the reference data
and the bitmaps produced by Ghostscript interpreting the vectorized
image. Apparently the threshold has become too low with the switch
to from Ghostscript 2.21 to 2.22.
--- potrace-1.15/check/postscript-check.sh 2018-01-06 19:47:26.194900686 +0100
+++ potrace-1.15/check/postscript-check.sh 2018-01-06 19:51:35.937503739 +0100
@@ -70,15 +70,15 @@ if test $? -ne 0; then
echo "Something is wrong with $GS; skipping this test" >& 2
exit 77
fi
-actiondiff "$TMP2" "$REFDATA" 1000
+actiondiff "$TMP2" "$REFDATA" 1500
action $POTRACE -r50 -p -L 0 -B 0 --opaque -o "$TMP1" "$DATA"
action "$GS" -q -dNOPAUSE -sDEVICE=pbmraw -g460x394 -r100x100 -sOutputFile="$TMP2" -- "$TMP1"
-actiondiff "$TMP2" "$REFDATA" 1200
+actiondiff "$TMP2" "$REFDATA" 1500
action $POTRACE -r50 -p -L 0 -B 0 -A 160 -o "$TMP1" "$DATA"
action "$GS" -q -dNOPAUSE -sDEVICE=pbmraw -g568x528 -r100x100 -sOutputFile="$TMP2" -- "$TMP1"
-actiondiff "$TMP2" "$REFDATAROT" 1200
+actiondiff "$TMP2" "$REFDATAROT" 1500
action rm -f "$TMP1"
action rm -f "$TMP2"
--- potrace-1.15/check/pdf-check.sh 2018-01-06 19:47:28.698886663 +0100
+++ potrace-1.15/check/pdf-check.sh 2018-01-06 20:54:14.895460329 +0100
@@ -72,15 +72,15 @@ if test $? -ne 0 -o ! -f "$TMP2"; then
echo "GS does not understand PDF; skipping this test" >& 2
exit 77
fi
-actiondiff "$TMP2" "$REFDATA" 1000
+actiondiff "$TMP2" "$REFDATA" 1500
action $POTRACE -r50 -p -L 0 -B 0 --opaque -b pdf -o "$TMP1" "$DATA"
action "$GS" -q -dNOPAUSE -sDEVICE=pbmraw -g460x394 -r100x100 -sOutputFile="$TMP2" -- "$TMP1"
-actiondiff "$TMP2" "$REFDATA" 1200
+actiondiff "$TMP2" "$REFDATA" 1500
action $POTRACE -r50 -p -L 0 -B 0 -A 160 -b pdf -o "$TMP1" "$DATA"
action "$GS" -q -dNOPAUSE -sDEVICE=pbmraw -g568x528 -r100x100 -sOutputFile="$TMP2" -- "$TMP1"
-actiondiff "$TMP2" "$REFDATAROT" 1200
+actiondiff "$TMP2" "$REFDATAROT" 1500
action rm -f "$TMP1"
action rm -f "$TMP2"
Diff finished. Sat Jan 6 20:54:50 2018
Age | Commit message (Expand) | Author |
2023-11-19 | linux-boot: Don't create /root before it's used....* gnu/build/linux-boot.scm (boot-system): Postpone the MKDIR of /root.
Change-Id: I589316a5ddf41cada02173ed4dd5b7df09b795e8
| Tobias Geerinckx-Rice |
2022-09-04 | linux-boot: Resume from hibernation after pre-boot....* gnu/build/linux-boot.scm (boot-system): Call resume-if-hibernated
after pre-mount.
Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
| Jack Hill |
2022-03-01 | initrd: Honor rootfstype and rootflags command-line parameters....* gnu/build/linux-boot.scm (boot-system): Honor rootfstype and rootflags
arguments. Update doc. Error out in case there is insufficient information
with regard to the root file system.
Restore the behavior of inferring the root device from the root file system
from the operating system in case the root argument is not provided.
* doc/guix.texi (Initial RAM Disk): Document the new command-line parameters.
| Maxim Cournoyer |
2022-03-01 | initrd: Use non-hyphenated kernel command-line parameter names....This is to make it less surprising, given the common convention sets forth by
the kernel Linux command-line parameters.
* gnu/build/linux-boot.scm (boot-system): Rename '--load', '--repl', '--root'
and '--system' to 'gnu.load', 'gnu.repl', 'root' and 'gnu.system',
respectively. Adjust doc.
(find-long-option): Adjust doc.
* gnu/installer/parted.scm (installer-root-partition-path): Adjust accordingly.
* gnu/system.scm (bootable-kernel-arguments): Add a VERSION argument and
update doc. Use VERSION to conditionally return old style vs new style initrd
arguments.
(%boot-parameters-version): Increment to 1.
(operating-system-boot-parameters): Adjust doc.
(operating-system-boot-parameters-file): Likewise.
* gnu/system/linux-initrd.scm (raw-initrd, base-initrd): Likewise.
* doc/guix.texi: Adjust doc.
* gnu/build/activation.scm (boot-time-system): Adjust accordingly.
* gnu/build/hurd-boot.scm (boot-hurd-system): Likewise.
* gnu/packages/commencement.scm (%final-inputs-riscv64): Adjust comment.
| Maxim Cournoyer |
2022-02-17 | build: linux-boot: Expound docstring of the 'boot-system' procedure....* gnu/build/linux-boot.scm (boot-system): Document the Linux command-line
parameters it understands and split a long string over two lines.
| Maxim Cournoyer |