diff --git a/src/common/exec.c b/src/common/exec.c
index f209b93..ed42202 100644
--- a/src/common/exec.c
+++ b/src/common/exec.c
@@ -238,6 +238,14 @@ find_my_exec(const char *argv0, char *retpath)
 static int
 normalize_exec_path(char *path)
 {
+	/*
+	 * Guix specific patch: postgresql extensions need to be located in the
+	 * same directory as postgresql.
+	 * In Guix we currently use directory-unions to create extended postgresql
+	 * packages. Directory unions use symlinks, that's why we need to be able
+	 * to use symlinks.
+	 */
+	return 0;
 	/*
 	 * We used to do a lot of work ourselves here, but now we just let
 	 * realpath(3) do all the heavy lifting.
-- 
2.46.0