Don't install systemd units unless using libsystemd session tracking. Submitted upstream: https://gitlab.freedesktop.org/polkit/polkit/-/merge_requests/134 diff --git a/data/meson.build b/data/meson.build --- a/data/meson.build +++ b/data/meson.build @@ -26,7 +26,7 @@ if enable_pam ) endif -if enable_logind +if session_tracking == 'libsystemd-login' configure_file( input: 'polkit.service.in', output: '@BASENAME@', diff --git a/meson.build b/meson.build --- a/meson.build +++ b/meson.build @@ -199,7 +199,7 @@ if enable_logind # systemd unit / service files systemd_systemdsystemunitdir = get_option('systemdsystemunitdir') - if systemd_systemdsystemunitdir == '' + if systemd_systemdsystemunitdir == '' and session_tracking == 'libsystemd-login' systemd_dep = dependency('systemd', not_found_message: 'systemd required but not found, please provide a valid systemd user unit dir or disable it') # FIXME: systemd.pc file does not use variables with relative paths, so `define_variable` cannot be used systemd_systemdsystemunitdir = systemd_dep.get_pkgconfig_variable('systemdsystemunitdir') 6ffb933cae'>refslogtreecommitdiff
path: root/tests/store-database.scm
AgeCommit message (Expand)Author
2024-04-15utils: Don’t re-export ‘call-with-temporary-output-file’....Ludovic Courtès
2024-04-03store: database: Rename a couple of procedures....Christopher Baines
2021-01-31database: Validate #:nar-size and #:time when registering store items....Ludovic Courtès
2020-12-15database: Remove 'register-path'....Ludovic Courtès
2020-12-15database: Remove #:deduplicate? and #:reset-timestamps? from 'register-path'....Ludovic Courtès
2020-11-21store-database: Add test checking the directory mtime after 'register-path'....Ludovic Courtès
2018-07-20database: Reset timestamps to one second after the Epoch....Ludovic Courtès
2018-06-14store: Remove 'register-path'....Ludovic Courtès
2018-06-14database: 'sqlite-register' takes a database, not a file name....Ludovic Courtès
2018-06-14database: Fail registration when encountering unregistered references....Ludovic Courtès
2018-06-14database: 'with-database' can now initialize new databases....Ludovic Courtès
2018-06-01Add (gnu store database)....Caleb Ristvedt