Don't install systemd units unless using libsystemd session tracking.
Submitted upstream:
https://gitlab.freedesktop.org/polkit/polkit/-/merge_requests/134
diff --git a/data/meson.build b/data/meson.build
--- a/data/meson.build
+++ b/data/meson.build
@@ -26,7 +26,7 @@ if enable_pam
)
endif
-if enable_logind
+if session_tracking == 'libsystemd-login'
configure_file(
input: 'polkit.service.in',
output: '@BASENAME@',
diff --git a/meson.build b/meson.build
--- a/meson.build
+++ b/meson.build
@@ -199,7 +199,7 @@ if enable_logind
# systemd unit / service files
systemd_systemdsystemunitdir = get_option('systemdsystemunitdir')
- if systemd_systemdsystemunitdir == ''
+ if systemd_systemdsystemunitdir == '' and session_tracking == 'libsystemd-login'
systemd_dep = dependency('systemd', not_found_message: 'systemd required but not found, please provide a valid systemd user unit dir or disable it')
# FIXME: systemd.pc file does not use variables with relative paths, so `define_variable` cannot be used
systemd_systemdsystemunitdir = systemd_dep.get_pkgconfig_variable('systemdsystemunitdir')
'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2024-12-03 | gnu: m4: Fix build of tests on the 64bit Hurd....* gnu/packages/m4.scm (m4)[arguments]: When building on the 64bit Hurd,
add CFLAGS to #:configure-flags.
Change-Id: Iab16194f4cd2911b4610dddd855064ddc4958dd9
| Janneke Nieuwenhuizen |
2024-12-03 | gnu: m4: Fix build for the 64bit Hurd....* gnu/packages/base.scm (grep)[arguments]: When building for the 64bit Hurd,
add patch-sigsegv.h stage.
Change-Id: I82993ebde268867348893556a9476faa5c4e9453
| Janneke Nieuwenhuizen |