This patch is borrowed from Debian's patches for plink Author: Peter Green Puropose: Fallback to endian.h if all else fails on 64bit machines Closes: #528659 Forwarded: Shaun Purcell License: same as plink itself. =================================================================== --- plink-1.06.orig/Rsrv.h 2009-05-15 03:35:29.000000000 +0100 +++ plink-1.06/Rsrv.h 2009-05-15 03:35:41.000000000 +0100 @@ -313,7 +313,18 @@ #define __BIG_ENDIAN__ 1 #define SWAPEND 1 #elif ! defined Win32 /* Windows is little-endian is most cases, anywhere else we're stuck */ -#error "Cannot determine endianness. Make sure config.h is included or __{BIG|LITTLE}_ENDIAN__ is defined ." + //try endian.h before we finally bail out + #include + #if __BYTE_ORDER == __LITTLE_ENDIAN + #warning using little endian based on information from endian.h + #define __LITTLE_ENDIAN__ 1 + #elif __BYTE_ORDER == __BIG_ENDIAN + #warning using big endian based on information from endian.h + #define __BIG_ENDIAN__ 1 + #define SWAPEND 1 + #else + #error "Cannot determine endianness. Make sure config.h is included or __{BIG|LITTLE}_ENDIAN__ is defined ." + #endif #endif /* FIXME: all the mess below needs more efficient implementation - the current one is so messy to work around alignment problems on some platforms like Sun and HP 9000 */ x/commit/gnu/packages/education.scm?id=43747274c38f2bb31f4407eedd3b0daed11f741c'>commitdiff
AgeCommit message (Collapse)Author
2024-04-06gnu: fet: Update to 6.19.0.Nicolas Goaziou
* gnu/packages/education.scm (fet): Update to 6.19.0. Change-Id: Icca4e8d8955a0fbaee9c91768b2630ccbf509ad7
2024-04-03gnu: qtsensors: Rename package to qtsensors-5.Zheng Junjie
* gnu/packages/qt.scm (qtsensors): Rename to qtsensors-5 * gnu/packages/qt.scm (python-pyqt, python-pyside-2) * gnu/packages/geo.scm (openorienteering-mapper) * gnu/packages/kde-plasma.scm (kscreen) * gnu/packages/education.scm (gcompris-qt) Adjust inputs. Change-Id: Ie18fdf82881e508ecc25c535088672d1a89f19ba Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
2024-03-17gnu: fet: Update to 6.18.1.Nicolas Goaziou
* gnu/packages/education.scm (fet): Update to 6.18.1. Change-Id: Idc0be5d9d8a3bea6e3a7826ae9a0ab0ee0ddf83d
2024-02-22gnu: Add tagainijisho.Tomas Volf
* gnu/packages/education.scm (tagainijisho): New variable. Change-Id: I85834c9e91a743540ef751e0c2bb3138b4c3b762 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
2024-02-13gnu: go-github-com-blang-semver: Move to golang-xyz.Sharlatan Hellseher
* gnu/packages/golang.scm (go-github-com-blang-semver): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/education.scm: Add (gnu packages golang-xyz) module. * gnu/packages/ipfs.scm: As above. Change-Id: I620543088661512bcc8135922a454c5f2dc73119
2024-02-13gnu: go-golang-org-x-net: Move to golang-build.Sharlatan Hellseher
* gnu/packages/golang.scm (go-golang-org-x-net, go-golang-org-x-net-0.17, go-golang-org-x-net-html): Move from here ... * gnu/packages/golang-build.scm: ... to here. * gnu/packages/configuration-management.scm: Add (gnu packages golang-build) module. * gnu/packages/education.scm: As above ... * gnu/packages/file-systems.scm: As above ... * gnu/packages/golang-check.scm: As above ... * gnu/packages/golang-crypto.scm: As above ... * gnu/packages/golang-web.scm: As above ... * gnu/packages/golang-xyz.scm: As above ... * gnu/packages/golang.scm: As above ... * gnu/packages/ipfs.scm: As above ... * gnu/packages/messaging.scm: As above ... * gnu/packages/networking.scm: As above ... * gnu/packages/uucp.scm: As above ... * gnu/packages/version-control.scm: As above ... Change-Id: If009e62555ada293f17cf0f42fde82c21ef4615e
2024-01-07gnu: fet: Update to 6.15.0.Nicolas Goaziou
* gnu/packages/education.scm (fet): Update to 6.15.0. Change-Id: Iec5ed880fd09dcc63e1650ceffc0f072c1236190