This patch is borrowed from Debian's patches for plink Author: Peter Green Puropose: Fallback to endian.h if all else fails on 64bit machines Closes: #528659 Forwarded: Shaun Purcell License: same as plink itself. =================================================================== --- plink-1.06.orig/Rsrv.h 2009-05-15 03:35:29.000000000 +0100 +++ plink-1.06/Rsrv.h 2009-05-15 03:35:41.000000000 +0100 @@ -313,7 +313,18 @@ #define __BIG_ENDIAN__ 1 #define SWAPEND 1 #elif ! defined Win32 /* Windows is little-endian is most cases, anywhere else we're stuck */ -#error "Cannot determine endianness. Make sure config.h is included or __{BIG|LITTLE}_ENDIAN__ is defined ." + //try endian.h before we finally bail out + #include + #if __BYTE_ORDER == __LITTLE_ENDIAN + #warning using little endian based on information from endian.h + #define __LITTLE_ENDIAN__ 1 + #elif __BYTE_ORDER == __BIG_ENDIAN + #warning using big endian based on information from endian.h + #define __BIG_ENDIAN__ 1 + #define SWAPEND 1 + #else + #error "Cannot determine endianness. Make sure config.h is included or __{BIG|LITTLE}_ENDIAN__ is defined ." + #endif #endif /* FIXME: all the mess below needs more efficient implementation - the current one is so messy to work around alignment problems on some platforms like Sun and HP 9000 */ 1bd5af7d673cb3c01c5e16d44380d84237fe'>diff
"guix build /….drv" correctly for non-existent derivations....
AgeCommit message (Expand)Author
2022-05-18services: Add more description fields....Ludovic Courtès
2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer
2021-04-12tests: Support package extensions in the backdoor REPL....Maxime Devos
2021-02-19tests: Export %simple-os....Mathieu Othacehe
Ludovic Courtès
2019-11-17tests: Test "guix build /gnu/store/….drv"....Ludovic Courtès
2019-11-07gnu: commencement: Ensure 'gnu-make-final' refers to the native 'pkg-config'....Ludovic Courtès
2019-07-20ui: 'warn-about-load-error' provides hints for unbound variables....Ludovic Courtès
2019-07-20ui: 'warn-about-load-error' warns about file/module name mismatches....Ludovic Courtès
2019-04-19guix build: Accept multiple '-s' options....Ludovic Courtès
2019-04-15guix build: Fix relative file name canonicalization for '--root'....Ludovic Courtès
2019-02-04daemon: Rename 'NIX_STATE_DIR' and 'NIX_DB_DIR' environment variables....Ludovic Courtès
2018-10-09guix build: '-f' accepts file-like objects....Ludovic Courtès
2018-05-04guix build: Nicely report unbound variables with hints....Ludovic Courtès
2018-03-13gnu: time: Update to 1.9....Efraim Flashner
2017-11-11tests: Refer to "time@1.8"....Ludovic Courtès