https://sources.debian.org/data/main/p/plib/1.8.5-8/debian/patches/04_CVE-2011-4620.diff
--- a/src/util/ulError.cxx
+++ b/src/util/ulError.cxx
@@ -39,7 +39,7 @@
{
va_list argp;
va_start ( argp, fmt ) ;
- vsprintf ( _ulErrorBuffer, fmt, argp ) ;
+ vsnprintf ( _ulErrorBuffer, sizeof(_ulErrorBuffer), fmt, argp ) ;
va_end ( argp ) ;
if ( _ulErrorCB )
>
|
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-08-31 | gnu: julia: Add 'bash' input for 'wrap-program'....It is required for cross-compilation.
* gnu/packages/julia.scm
(julia)[inputs]: Add 'bash-minimal'.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I279650a3de44f03b2a4a23012ce8125f85ebbe0b
| Maxime Devos |