https://sources.debian.org/data/main/p/plib/1.8.5-8/debian/patches/04_CVE-2011-4620.diff
--- a/src/util/ulError.cxx
+++ b/src/util/ulError.cxx
@@ -39,7 +39,7 @@
{
va_list argp;
va_start ( argp, fmt ) ;
- vsprintf ( _ulErrorBuffer, fmt, argp ) ;
+ vsnprintf ( _ulErrorBuffer, sizeof(_ulErrorBuffer), fmt, argp ) ;
va_end ( argp ) ;
if ( _ulErrorCB )
r>
|
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-06-14 | gnu: Rename qtbase to qtbase-5....This change was automated via the following command:
$ git ls-files | xargs sed -i 's/,qtbase)/,qtbase-5)/g'
$ git ls-files | xargs sed -i 's/inherit qtbase)/inherit qtbase-5)/g'
$ git ls-files | xargs sed -i 's/package-version qtbase)/package-version qtbase-5)/g'
$ git checkout etc # to clear some spurious changes
This is done so the qtbase package can be upgraded to version 6 in the
following commit.
| Maxim Cournoyer |
2021-03-02 | gnu: Add gimagereader....* gnu/packages/ocr.scm (gimagereader): New variable.
| Nicolas Goaziou |
2021-02-13 | gnu: tesseract-ocr: Update to 4.1.1-1.97079fa...* gnu/packages/ocr.scm (tesseract-ocr): Update to 4.1.1-1.97079fa
Signed-off-by: Jelle Licht <jlicht@fsfe.org>
| andy Tai |