https://sources.debian.org/data/main/p/plib/1.8.5-8/debian/patches/04_CVE-2011-4620.diff
--- a/src/util/ulError.cxx
+++ b/src/util/ulError.cxx
@@ -39,7 +39,7 @@
{
va_list argp;
va_start ( argp, fmt ) ;
- vsprintf ( _ulErrorBuffer, fmt, argp ) ;
+ vsnprintf ( _ulErrorBuffer, sizeof(_ulErrorBuffer), fmt, argp ) ;
va_end ( argp ) ;
if ( _ulErrorCB )
|
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-05-15 | locale: Use the native gzip and libc when building locales....This fixes system cross-compilation.
* gnu/system/locale.scm (single-locale-directory)[build]: Use the native
GZIP and LIBC.
| Ludovic Courtès |
2020-05-03 | locale: Add glibc 2.29 to '%default-locale-libcs'....This eases transition for anyone reconfiguring and still having profiles
with packages using the former libc.
* gnu/system/locale.scm (%default-locale-libcs): Add GLIBC-2.29.
| Ludovic Courtès |
2020-02-12 | system: locale: Remove canonical-package call....This is a follow-up of dfc8ccbf5da96a67eb1cade499f0def21e7fdb02. Building
locales using the same glibc as the one programs are linked against is
enough.
* gnu/system/locale.scm (%default-locale-libcs): Use the plain glibc package.
| Mathieu Othacehe |
2020-02-11 | system: Stop using canonical-package....Usage of canonical-package outside of thunked fields breaks cross-compilation,
see: https://lists.gnu.org/archive/html/guix-devel/2019-12/msg00410.html.
* gnu/installer.scm (installer-program): Remove canonical-package.
* gnu/services/base.scm (<nscd-cache>): Ditto,
(%base-services): ditto.
* gnu/services/xorg.scm: Remove useless canonical-package import.
* gnu/system.scm (%base-packages): Remove canonical-package.
* gnu/system/install.scm (%installation-services): Ditto,
(installation-os): ditto.
* gnu/system/locale.scm (single-locale-directory): Ditto.
| Mathieu Othacehe |
2019-06-07 | Add (gnu build locale)....* gnu/build/locale.scm: New file.
* gnu/local.mk (MODULES_NOT_COMPILED): Add it.
* gnu/installer/locale.scm (normalize-codeset): Remove.
* gnu/system/locale.scm (localedef-command): Remove.
(single-locale-directory): Use (gnu build locale).
(glibc-supported-locales)[build]: Likewise, and remove
'read-supported-locales'.
| Ludovic Courtès |
2019-05-13 | locale: Add 'glibc-supported-locales'....* gnu/system/locale.scm (glibc-supported-locales): New procedure.
| Ludovic Courtès |