https://sources.debian.org/data/main/p/plib/1.8.5-8/debian/patches/04_CVE-2011-4620.diff
--- a/src/util/ulError.cxx
+++ b/src/util/ulError.cxx
@@ -39,7 +39,7 @@
{
va_list argp;
va_start ( argp, fmt ) ;
- vsprintf ( _ulErrorBuffer, fmt, argp ) ;
+ vsnprintf ( _ulErrorBuffer, sizeof(_ulErrorBuffer), fmt, argp ) ;
va_end ( argp ) ;
if ( _ulErrorCB )
>
|
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-02-15 | gnu: cmake-shared: Update to 1.1.0-32....* gnu/packages/cmake.scm (cmake-shared): Update to 1.1.0-32.
[source]: Add snippet to remove bundled sources.
Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
| Raghav Gururajan |
2021-01-31 | gnu: Add cmake-shared....* gnu/packages/cmake.scm (cmake-shared): New variable.
Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
| Raghav Gururajan |
2020-12-26 | gnu: cmake: Update to 3.19.2....* gnu/packages/cmake.scm (cmake): Update to 3.19.2.
Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
| Greg Hogan |
2020-11-26 | gnu: cmake: Update to 3.19.1....* gnu/packages/cmake.scm (cmake): Update to 3.19.1.
| Tobias Geerinckx-Rice |
2020-11-24 | gnu: cmake: Update to 3.19.0....* gnu/packages/cmake.scm (cmake): Update to 3.19.0.
[source]: Modify inherited source to adjust the hash as well as the snippet so
that the "Utilities/cm3p" sub-directory is preserved.
[phases]{patch-bin-sh, check}: Temporarily overrides until the next rebuild
cycle.
| Maxim Cournoyer |
2020-11-08 | gnu: cmake: Update source URI....* gnu/packages/cmake.scm (cmake-bootstrap)[source]: Update to new source
URI.
| Efraim Flashner |