Fixes 'multiple definition errors' when building with GCC 10+
From: https://bugs.gentoo.org/710796
Originally from: https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/a62e41e
and https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/7a976c7
--- a/spa/plugins/bluez5/a2dp-codecs.h
+++ b/spa/plugins/bluez5/a2dp-codecs.h
@@ -284,15 +284,15 @@
}
}
-const a2dp_sbc_t bluez_a2dp_sbc;
+extern const a2dp_sbc_t bluez_a2dp_sbc;
#if ENABLE_MP3
-const a2dp_mpeg_t bluez_a2dp_mpeg;
+extern const a2dp_mpeg_t bluez_a2dp_mpeg;
#endif
#if ENABLE_AAC
-const a2dp_aac_t bluez_a2dp_aac;
+extern const a2dp_aac_t bluez_a2dp_aac;
#endif
#if ENABLE_APTX
-const a2dp_aptx_t bluez_a2dp_aptx;
+extern const a2dp_aptx_t bluez_a2dp_aptx;
#endif
#endif
--- a/spa/plugins/bluez5/bluez5-monitor.c
+++ b/spa/plugins/bluez5/bluez5-monitor.c
@@ -75,7 +75,7 @@
struct spa_list transport_list;
};
-struct spa_handle_factory spa_a2dp_sink_factory;
+extern struct spa_handle_factory spa_a2dp_sink_factory;
static void fill_item(struct spa_bt_monitor *this, struct spa_bt_transport *transport,
struct spa_pod **result, struct spa_pod_builder *builder)
--- a/spa/plugins/bluez5/meson.build
+++ b/spa/plugins/bluez5/meson.build
@@ -1,7 +1,8 @@
bluez5_sources = ['plugin.c',
'a2dp-sink.c',
- 'bluez5-monitor.c']
+ 'a2dp-codecs.c',
+ 'bluez5-monitor.c']
bluez5lib = shared_library('spa-bluez5',
bluez5_sources,
l.in?id=2d4b61d014ce6daba6bc6c39df77a0c46cffe55c'>diff
|
Age | Commit message (Expand) | Author |
2022-12-23 | etc: SELinux: Allow init process to setattr on profile directories....* etc/guix-daemon.cil.in: Add rule.
| Ricardo Wurmus |
2022-12-23 | etc: SELinux: Allow daemon to search run state directories....* etc/guix-daemon.cil.in: Import types init_var_run_t and
system_dbusd_var_run_t; add rules.
| Ricardo Wurmus |
2022-12-23 | etc: SELinux: Label guix-daemon executable in profile....* etc/guix-daemon.cil.in: Add file rule for "guix-daemon" in current-guix
profile.
| Ricardo Wurmus |
2022-01-26 | etc: Remove redundant SELinux permissions block....* etc/guix-daemon.cil.in (guix_daemon): Consolidate two blocks adding
sock_file permissions on guix_daemon_conf_t.
| Marius Bakke |
2022-01-24 | etc: Add more SELinux permissions for the daemon....* etc/guix-daemon.cil.in (guix_daemon): Permit write on guix_daemon_conf_t
sock_file, necessary for garbage collection.
| Marius Bakke |
2021-05-22 | etc: Add more SELinux permissions for the daemon....* etc/guix-daemon.cil.in (guix_daemon): Add more permissions, necessary for
garbage collection.
| Marius Bakke |
2020-12-10 | etc: Add more SELinux permissions for the daemon....* etc/guix-daemon.cil.in (guix_daemon): Permit file write, getattr, link and
unlink for the guix_daemon_exec_t type.
| Marius Bakke |
2020-11-27 | etc: Add more SELinux permissions for the daemon....* etc/guix-daemon.cil.in (guix_daemon): Permit more operations required for
various build jobs.
| Marius Bakke |
2020-11-26 | etc: Add more SELinux permissions for the daemon....* etc/guix-daemon.cil.in (guix_daemon): Permit file appending, setattr,
read/write UDP sockets, access to tmpfs and hugetlbfs, and connecting to
PostgreSQL.
| Marius Bakke |
2020-11-25 | etc: Add more SELinux permissions for the daemon....This is needed for some package test suites.
* etc/guix-daemon.cil.in (guix_daemon): Permit unix_dgram_socket operations.
| Marius Bakke |
2020-11-15 | etc: Updates for the guix-daemon SELinux policy....* etc/guix-daemon.cil.in (guix_daemon): Specify more permissions for
guix-daemon to account for daemon updates and newer SELinux.
I can't promise that this is a complete list of everything that guix-daemon
needs, but it's probably most of them. It can search for, install, upgrade,
and remove packages, create virtual machines and containers, update itself,
and so on.
Signed-off-by: Marius Bakke <marius@gnu.org>
| Daniel Brooks |