Do not assume the SDL_image and SLD_mixer libraries are installed at the same
prefix reported by sdl-config, but instead get flags from the pkg-config files
installed with these libraries.
--- a/SConscript 2011-12-24 15:46:47.000000000 -0600
+++ b/SConscript 2014-06-12 21:20:45.702668330 -0500
@@ -199,7 +199,13 @@
self.fatal_error += " * library 'png' not found\n"
def configure_sdl(self):
- if self.conf.CheckMyProgram('sdl-config'):
+ if self.conf.CheckMyProgram('pkg-config'):
+ self.conf.env.ParseConfig("pkg-config --cflags --libs sdl")
+ for sdllib in ['image', 'mixer']:
+ self.conf.env.ParseConfig("pkg-config --cflags --libs SDL_%s" % sdllib)
+ if not self.conf.CheckSDLLib(sdllib):
+ self.fatal_error += " * SDL library '%s' not found\n" % sdllib
+ elif self.conf.CheckMyProgram('sdl-config'):
self.conf.env.ParseConfig("sdl-config --cflags --libs | sed 's/-I/-isystem/g'")
for sdllib in ['image', 'mixer']:
if not self.conf.CheckSDLLib(sdllib):
44bb927fc88223a15431428cb741dd1c2c'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2022-02-26 | installer: Continue even if Connman cannot phone home....Connman's online check is unreliable for me.
* gnu/installer/connman.scm (connman-online?): Accept if
connman state is ready instead of online.
| Florian Pelz |
2020-09-21 | installer: Fix docstring typoes....* gnu/installer/connman.scm (connman-state, run-locale-page)
(start-swapping, stop-swapping, run-installer-steps): Fix typo in
docstring.
| Tobias Geerinckx-Rice |
2020-04-19 | installer: connman: Fix Wifi connection....Issue reported by SergioBG here:
https://lists.gnu.org/archive/html/bug-guix/2020-04/msg00432.html.
Due to default buffering mode, the installer was reading from the pipe without
having actually written a command before.
* gnu/installer/connman.scm (connman-connect-with-auth): Set pipe buffering
mode to 'line.
| Mathieu Othacehe |