Do not assume the SDL_image and SLD_mixer libraries are installed at the same prefix reported by sdl-config, but instead get flags from the pkg-config files installed with these libraries. --- a/SConscript 2011-12-24 15:46:47.000000000 -0600 +++ b/SConscript 2014-06-12 21:20:45.702668330 -0500 @@ -199,7 +199,13 @@ self.fatal_error += " * library 'png' not found\n" def configure_sdl(self): - if self.conf.CheckMyProgram('sdl-config'): + if self.conf.CheckMyProgram('pkg-config'): + self.conf.env.ParseConfig("pkg-config --cflags --libs sdl") + for sdllib in ['image', 'mixer']: + self.conf.env.ParseConfig("pkg-config --cflags --libs SDL_%s" % sdllib) + if not self.conf.CheckSDLLib(sdllib): + self.fatal_error += " * SDL library '%s' not found\n" % sdllib + elif self.conf.CheckMyProgram('sdl-config'): self.conf.env.ParseConfig("sdl-config --cflags --libs | sed 's/-I/-isystem/g'") for sdllib in ['image', 'mixer']: if not self.conf.CheckSDLLib(sdllib): 9ddec8f4a181be653152c7436581c2adc54eee'>refslogtreecommitdiff
path: root/gnu/packages/shellutils.scm
AgeCommit message (Expand)Author
2024-02-13gnu: go-golang-org-x-mod: Move to golang-build....Sharlatan Hellseher
2024-02-13gnu: go-github-com-burntsushi-toml: Move to golang-xyz....Sharlatan Hellseher
2024-01-05gnu: grml-zsh-config: Update to 0.19.6....kiasoc5
2023-12-23gnu: fzy: Fix cross-compilation....Zheng Junjie
2023-12-23gnu: fzy: Use Gexps....Zheng Junjie
2023-12-22gnu: Add liquidprompt....Romain GARBAGE
2023-09-10gnu: conflict: Update to 20221002....Tobias Geerinckx-Rice
2023-09-10gnu: boxes: Update to 2.2.1....Tobias Geerinckx-Rice
2023-07-28gnu: direnv: Update to 2.32.3....Distopico
2023-07-10gnu: zsh-autosuggestions: Remove ruby-byebug dependency....Christopher Baines