Fixes error during make:
"No rule to make target '../src/libemilia_pin.a', needed by 'pinball'. Stop."
--- pinball-0.3.1/src/Makefile.in 2003-12-10 05:34:47.000000000 -0600
+++ pinball-0.3.1/src/Makefile.in 2016-01-31 22:29:13.134519889 -0600
@@ -116,7 +116,7 @@
INCLUDES = -I../base -I../addon @INCLTDL@
-pinball_LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
+pinball_LDADD = libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
pinball_LDFLAGS = -export-dynamic
pinball_SOURCES = Pinball.cpp
@@ -174,7 +174,7 @@
am_pinball_OBJECTS = Pinball.$(OBJEXT)
pinball_OBJECTS = $(am_pinball_OBJECTS)
-pinball_DEPENDENCIES = ../src/libemilia_pin.a ../addon/libemilia_addon.a \
+pinball_DEPENDENCIES = libemilia_pin.a ../addon/libemilia_addon.a \
../base/libemilia_base.a
DEFS = @DEFS@
'submit' value='switch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2020-12-08 | daemon: 'Agent' constructor takes a list of environment variables....* nix/libutil/util.hh (struct Agent)[Agent]: Add 'env' parameter.
* nix/libutil/util.cc (Agent::Agent): Honor it.
| Ludovic Courtès |
2020-09-14 | daemon: Move 'Agent' to libutil....* nix/libstore/build.cc (DerivationGoal::tryBuildHook): Add "offload" to
'args' and pass settings.guixProgram as the first argument to
Agent::Agent.
(pathNullDevice, commonChildInit, Agent, Agent::Agent)
(Agent::~Agent): Move to...
* nix/libutil/util.cc: ... here.
* nix/libutil/util.hh (struct Agent, commonChildInit): New
declarations.
| Ludovic Courtès |
2020-01-12 | daemon: Account for deleted store files when deduplication is on....Previously, a store item that is a regular file would not be accounted
for in the 'bytesFreed' value computed by 'deletePath' because its
'st_nlink' count would always be >= 2. This commit fixes that.
* nix/libutil/util.hh (deletePath): Add optional 'linkThreshold' argument.
* nix/libutil/util.cc (_deletePath): Add 'linkThreshold' argument and
honor it. Pass it down in recursive call.
(deletePath): Add 'linkThreshold' and honor it.
* nix/libstore/gc.cc (LocalStore::deleteGarbage): Pass 'linkThreshold'
argument to 'deletePath', with a value of 2 when PATH is a store item
and deduplication is on.
| Ludovic Courtès |