--- pinball-0.3.1/base/Config.cpp 2009-10-13 18:33:38.000000000 +0200
+++ pinball-0.3.1/base/Config.cpp 2009-10-13 18:37:12.000000000 +0200
@@ -416,7 +416,7 @@
m_sDataDir = string(EM_DATADIR) + "/";
m_sExeDir = "./";
if ( *( m_sDataDir.c_str() ) != '/' ) {
- char* ptr=0;
+ const char* ptr=0;
char* ptrw = 0;
//cout<<"relative to exe file"<
index : guix | |
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-03-16 | system: Improve 'read-boot-parameters' incompatibility diagnostic....Previously, when reading an incompatible "parameters" file, 'guix
system' would print a warning and then crash with a wrong-type-arg
backtrace because code expects 'read-boot-parameters' to always return a
<boot-parameters> record.
* gnu/system.scm (read-boot-parameters): Upon incompatibility, raise an
error instead of returning #f. Also raise a '&fix-hint' condition.
* tests/boot-parameters.scm ("read, construction, mandatory fields"):
Define 'test-read-boot-parameters' as a macro; expect
'formatted-message?' exceptions rather than #f returns.
| Ludovic Courtès |