Support the PURPLE_PLUGIN_PATH environment variable. This patch is based on
one from Nixpkgs, but properly handles the case where that variable is unset.
--- pidgin-2.10.11/libpurple/plugin.c.orig 2014-11-23 11:41:25.000000000 -0500
+++ pidgin-2.10.11/libpurple/plugin.c 2015-08-04 14:31:02.257366144 -0400
@@ -1178,8 +1178,19 @@
void
purple_plugins_init(void) {
void *handle = purple_plugins_get_handle();
+ const gchar *purple_plugin_path;
purple_plugins_add_search_path(LIBDIR);
+ purple_plugin_path = g_getenv("PURPLE_PLUGIN_PATH");
+ if (purple_plugin_path && *purple_plugin_path) {
+ gchar **paths = g_strsplit(purple_plugin_path, ":", -1);
+ if (paths) {
+ gchar **p;
+ for (p = paths; *p; ++p)
+ if (**p) purple_plugins_add_search_path(*p);
+ }
+ g_strfreev(paths);
+ }
purple_signal_register(handle, "plugin-load",
purple_marshal_VOID__POINTER,
form>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-05-31 | gnu: java-pep-adapter 2.1.23....* gnu/packages/pep.scm (java-pep-adapter): Update to 2.1.23.
[source]: Switch to new git repo.
[arguments]<make-flags>: Enable release-build, use new target names.
[arguments]<phases>{fix-includes}: Remove phase.
{pin-shared-lib-path}: Update file paths.
{build-codegen}: New phase.
{install}: Use "(install)".
[native-inputs]: Add graphviz.
[inputs]: Fix input util-linux.
| Hartmut Goebel |
2021-05-31 | gnu: python-pep-adapter: Update to 2.1.3....* gnu/packages/pep.scm (python-pep-adapter): Update to 2.1.3.
[source]: Switch to new git repo.
[arguments]<phases>{remove-wheel-requirement}: New phase.
[native-inputs]: Add python-pytest and python-pytest-forked.
[inputs]: Remove asn1c, add python-setuptools-scm. util-linux.
| Hartmut Goebel |
2021-05-31 | gnu: libpEpAdapter: Update to 2.1.21....* gnu/packages/pep.scm (libpEpAdapter): Update to 2.1.21.
[source]: Swicht to new git repo.
[arguments]<make-flags>: Enable release-build.
| Hartmut Goebel |
2021-05-31 | gnu: pep-engine: Update to 2.1.34....* gnu/packages/pep.scm (fdik-libetpan): Update to current development
version. [source]: Switch to pep.foundation.
(pep-engine): Update to 2.1.34. [source]: Switch to new git repo.
[arguments]<make-flags>: Enable release-build.
[inputs]: Use normal sequoia.
* gnu/packages/sequoia.scm (sequoia4pEp): Remove variable.
| Hartmut Goebel |
2021-05-31 | gnu: yml2: Update to 2.7.0....* gnu/packages/pep.scm (yml2): Update to 2.7.0.
[source]: Switch to new git repo.
| Hartmut Goebel |
2021-03-22 | gnu: sequoia4pEp: Move to sequoia.scm....Don't have cross module package inheritance.
* gnu/packages/pep.scm (sequoia4pEp): Move to ...
* gnu/packages/sequoia.scm (sequoia4pEp): ... here. Hide package.
| Efraim Flashner |