Support the PURPLE_PLUGIN_PATH environment variable. This patch is based on one from Nixpkgs, but properly handles the case where that variable is unset. --- pidgin-2.10.11/libpurple/plugin.c.orig 2014-11-23 11:41:25.000000000 -0500 +++ pidgin-2.10.11/libpurple/plugin.c 2015-08-04 14:31:02.257366144 -0400 @@ -1178,8 +1178,19 @@ void purple_plugins_init(void) { void *handle = purple_plugins_get_handle(); + const gchar *purple_plugin_path; purple_plugins_add_search_path(LIBDIR); + purple_plugin_path = g_getenv("PURPLE_PLUGIN_PATH"); + if (purple_plugin_path && *purple_plugin_path) { + gchar **paths = g_strsplit(purple_plugin_path, ":", -1); + if (paths) { + gchar **p; + for (p = paths; *p; ++p) + if (**p) purple_plugins_add_search_path(*p); + } + g_strfreev(paths); + } purple_signal_register(handle, "plugin-load", purple_marshal_VOID__POINTER, Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/wget.scm
AgeCommit message (Expand)Author
2020-09-05Merge remote-tracking branch 'origin/master' into stagingEfraim Flashner
2020-09-01gnu: wgetpaste: Update bpaste URL & regular expressions....* gnu/packages/wget.scm (wgetpaste)[source]: Add patch. * gnu/packages/patches/wgetpaste-update-bpaste.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Tobias Geerinckx-Rice
2020-09-01gnu: wgetpaste: Update to 2.30....* gnu/packages/wget.scm (wgetpaste): Update to 2.30. Tobias Geerinckx-Rice
2020-09-01gnu: wgetpaste: Use HTTPS home page....* gnu/packages/wget.scm (wgetpaste)[source, home-page]: Use HTTPS. Tobias Geerinckx-Rice
2020-09-01gnu: wgetpaste: Fix historical confusion....* gnu/packages/wget.scm (wgetpaste)[arguments]: Fix the reversed substitution and clarify its purpose. Tobias Geerinckx-Rice
2020-07-03gnu: wget: Cross-build fix....* gnu/packages/wget.scm (wget)[inputs]: Move lzip to ... [native-inputs]: ... here. Jan (janneke) Nieuwenhuizen
2020-04-22gnu: wget2: Add support for gnu updater....* gnu/packages/wget.scm (wget2)[properties]: New field. Add ftp-directory. Efraim Flashner