Support the PURPLE_PLUGIN_PATH environment variable. This patch is based on
one from Nixpkgs, but properly handles the case where that variable is unset.
--- pidgin-2.10.11/libpurple/plugin.c.orig 2014-11-23 11:41:25.000000000 -0500
+++ pidgin-2.10.11/libpurple/plugin.c 2015-08-04 14:31:02.257366144 -0400
@@ -1178,8 +1178,19 @@
void
purple_plugins_init(void) {
void *handle = purple_plugins_get_handle();
+ const gchar *purple_plugin_path;
purple_plugins_add_search_path(LIBDIR);
+ purple_plugin_path = g_getenv("PURPLE_PLUGIN_PATH");
+ if (purple_plugin_path && *purple_plugin_path) {
+ gchar **paths = g_strsplit(purple_plugin_path, ":", -1);
+ if (paths) {
+ gchar **p;
+ for (p = paths; *p; ++p)
+ if (**p) purple_plugins_add_search_path(*p);
+ }
+ g_strfreev(paths);
+ }
purple_signal_register(handle, "plugin-load",
purple_marshal_VOID__POINTER,
value='switch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-05-27 | mapped-devices: lvm: Add missing module import....Tested with (locally fixed) lvm-separate-home-os system test.
* gnu/system/mapped-devices.scm (lvm-device-mapping): Add SRFI-1 to
modules.
Change-Id: I8c155b47c29004bdc59057391dfba94ce33bdbc2
| Lars-Dominik Braun |
2024-04-08 | mapped-devices: luks: Specify modules needed at the top-level....Fixes <https://issues.guix.gnu.org/70266>.
* gnu/system/mapped-devices.scm (luks-device-mapping)[modules]: New
field.
(open-luks-device): Remove non-top-level ‘use-modules’ form.
* gnu/system/linux-initrd.scm (raw-initrd): Remove modules that were
added specifically for ‘luks-device-mapping’.
Change-Id: I4253c3dd5e3cbcee41ec84fd57227abd428d1bd6
| Ludovic Courtès |
2024-04-08 | mapped-devices: <mapped-device-type> can specify modules to import....* gnu/system/mapped-devices.scm (<mapped-device-type>)[modules]: New
field.
(device-mapping-service-type): Honor it.
* gnu/system/linux-initrd.scm (raw-initrd): Likewise.
Change-Id: Icc702cb6f281741975e33203f87fbc1ffa9856da
| Ludovic Courtès |
2024-01-14 | mapped-devices: Allow unlocking by a key file....Requiring the user to input their password in order to unlock a device is not
always reasonable, so having an option to unlock the device using a key file
is a nice quality of life change.
* gnu/system/mapped-devices.scm (open-luks-device): Add #:key-file argument.
(luks-device-mapping-with-options): New procedure.
* doc/guix.texi (Mapped Devices): Describe the new procedure.
Change-Id: I1de4e045f8c2c11f9a94f1656e839c785b0c11c4
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Tomas Volf |