Support the PURPLE_PLUGIN_PATH environment variable. This patch is based on one from Nixpkgs, but properly handles the case where that variable is unset. --- pidgin-2.10.11/libpurple/plugin.c.orig 2014-11-23 11:41:25.000000000 -0500 +++ pidgin-2.10.11/libpurple/plugin.c 2015-08-04 14:31:02.257366144 -0400 @@ -1178,8 +1178,19 @@ void purple_plugins_init(void) { void *handle = purple_plugins_get_handle(); + const gchar *purple_plugin_path; purple_plugins_add_search_path(LIBDIR); + purple_plugin_path = g_getenv("PURPLE_PLUGIN_PATH"); + if (purple_plugin_path && *purple_plugin_path) { + gchar **paths = g_strsplit(purple_plugin_path, ":", -1); + if (paths) { + gchar **p; + for (p = paths; *p; ++p) + if (**p) purple_plugins_add_search_path(*p); + } + g_strfreev(paths); + } purple_signal_register(handle, "plugin-load", purple_marshal_VOID__POINTER, ass='sub'>Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/ROADMAP
doc/local.mk?id=663b5d2abbc8938f821872dcf28e67826b4180ba&showmsg=1'>Expand)
AgeCommit message (Expand)Author
Author
2022-11-19doc: Build more man pages....Hilton Chain
2022-04-02nls: Enforce translation thresholds....Julien Lepiller
2022-03-01nls: Update translations....Julien Lepiller
2022-02-04nls: Update translations....Julien Lepiller
2022-01-09nls: Update translations....Julien Lepiller
2021-11-14doc: Add example to dist target....Julien Lepiller
2021-11-06nls: Update translations....Julien Lepiller
2021-10-22doc: Set LC_ALL when translating xref commands....Julien Lepiller
2021-10-17maint: Factorize po xref translation....Julien Lepiller
2021-08-04nls: Update translations....Julien Lepiller