https://sources.debian.org/data/main/p/picprog/1.9.1-3/debian/patches/20_iopl.patch Description: Avoid some functions in some architectures Upstream uses iopl() function and other architecture-dependent codes. This patch adds building switches to avoid them in some architectures. Author: Koichi Akabe Last-Update: 2011-11-30 --- picprog-1.9.1.orig/picport.cc +++ picprog-1.9.1/picport.cc @@ -38,7 +38,12 @@ #include #include -#include + +#if defined(__i386__) || defined(__x86_64__) + #include + #define HAVE_IOPL +#endif + #include #include #include @@ -160,8 +165,12 @@ // Not root. Cannot use realtime scheduling. use_nanosleep = 0; } +#ifdef HAVE_IOPL if (iopl (3)) disable_interrupts = 0; +#else + disable_interrupts = 0; +#endif #ifdef CPU_SETSIZE // When computing the delay loops, we do not want the cpu's to change. @@ -403,13 +412,17 @@ { struct timeval tv1, tv2; gettimeofday (&tv1, 0); +#if defined(__i386__) or defined(__x86_64__) if (tsc_1000ns > 1 && disable_interrupts) asm volatile("pushf; cli"); +#endif set_clock_data (1, b); // set data, clock up delay (cable_delay); set_clock_data (0, b); // clock down +#if defined(__i386__) or defined(__x86_64__) if (tsc_1000ns > 1 && disable_interrupts) asm volatile("popf"); +#endif gettimeofday (&tv2, 0); // We may have spent a long time in an interrupt or in another task @@ -428,13 +441,17 @@ { struct timeval tv1, tv2; gettimeofday (&tv1, 0); +#if defined(__i386__) or defined(__x86_64__) if (tsc_1000ns > 1 && disable_interrupts) asm volatile("pushf; cli"); +#endif set_clock_data (1, 1); // clock up delay (cable_delay); set_clock_data (0, 1); // set data up, clock down +#if defined(__i386__) or defined(__x86_64__) if (tsc_1000ns > 1 && disable_interrupts) asm volatile("popf"); +#endif gettimeofday (&tv2, 0); // We may have spent a long time in an interrupt or in another task ot/doc/build.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-11-02 00:22:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-11-02 00:36:02 +0100
commitc6c0d396240e5a4977dc96a5e16735c69fd61a53 (patch)
tree6a41102e0a7e94284b949c6f730b0d4dc38f9e63 /doc/build.scm
parentd939b2955d8de2084f550a9063ce0c8006ecc4fa (diff)
downloadguix-c6c0d396240e5a4977dc96a5e16735c69fd61a53.tar.gz
guix-c6c0d396240e5a4977dc96a5e16735c69fd61a53.zip
gnu: synthv1: Update to 0.9.11.
* gnu/packages/music.scm (synthv1): Update to 0.9.11.
Diffstat (limited to 'doc/build.scm')
0 files changed, 0 insertions, 0 deletions