https://sources.debian.org/data/main/p/picprog/1.9.1-3/debian/patches/20_iopl.patch Description: Avoid some functions in some architectures Upstream uses iopl() function and other architecture-dependent codes. This patch adds building switches to avoid them in some architectures. Author: Koichi Akabe Last-Update: 2011-11-30 --- picprog-1.9.1.orig/picport.cc +++ picprog-1.9.1/picport.cc @@ -38,7 +38,12 @@ #include #include -#include + +#if defined(__i386__) || defined(__x86_64__) + #include + #define HAVE_IOPL +#endif + #include #include #include @@ -160,8 +165,12 @@ // Not root. Cannot use realtime scheduling. use_nanosleep = 0; } +#ifdef HAVE_IOPL if (iopl (3)) disable_interrupts = 0; +#else + disable_interrupts = 0; +#endif #ifdef CPU_SETSIZE // When computing the delay loops, we do not want the cp
aboutsummaryrefslogtreecommitdiff
ge (Collapse)
AgeCommit message (Expand)Author
Author
2020-06-09git: 'commit-difference' really excludes the ancestors of #:excluded.Ludovic Courtès
* guix/git.scm (commit-difference): Initialize VISITED to the closure of OLD and EXCLUDED, as written in the docstring. * tests/git.scm ("commit-difference, excluded commits"): Adjust accordingly.
2020-05-25git: Add 'commit-relation'.Ludovic Courtès
* guix/git.scm (commit-relation): New procedure. * tests/git.scm ("commit-relation"): New test.
2019-12-27git: 'commit-difference' takes a list of excluded commits.Ludovic Courtès
* guix/git.scm (commit-closure): Add 'visited' optional parameter. (commit-difference): Add 'excluded' optional parameter; pass second argument to 'commit-closure'. * tests/git.scm ("commit-difference, excluded commits"): New test.