diff -Naur a/gui/bank-ops.c b/gui/bank-ops.c --- a/gui/bank-ops.c 2012-08-06 05:33:34.000000000 +0200 +++ b/gui/bank-ops.c 2012-08-07 17:57:28.580145691 +0200 @@ -393,6 +393,8 @@ g_signal_connect_swapped(G_OBJECT(msg), "response", G_CALLBACK(gtk_widget_destroy), msg); gtk_widget_show (msg); + + gtk_recent_manager_remove_item(recent_manager, filename, NULL); } else { diff -Naur a/libpetrifui/dish_file.c b/libpetrifui/dish_file.c --- a/libpetrifui/dish_file.c 2012-08-06 05:33:34.000000000 +0200 +++ b/libpetrifui/dish_file.c 2012-08-07 17:56:09.063909801 +0200 @@ -1440,7 +1440,7 @@ if (stat(path, &st) != 0) { - msg_log(MSG_ERROR, "file '%s' does not exist\n"); + msg_log(MSG_ERROR, "file '%s' does not exist\n", path); return -1; } ripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/mapped-devices.scm
AgeCommit message (Collapse)Author
2024-04-08mapped-devices: luks: Specify modules needed at the top-level.Ludovic Courtès
Fixes <https://issues.guix.gnu.org/70266>. * gnu/system/mapped-devices.scm (luks-device-mapping)[modules]: New field. (open-luks-device): Remove non-top-level ‘use-modules’ form. * gnu/system/linux-initrd.scm (raw-initrd): Remove modules that were added specifically for ‘luks-device-mapping’. Change-Id: I4253c3dd5e3cbcee41ec84fd57227abd428d1bd6
2024-04-08mapped-devices: <mapped-device-type> can specify modules to import.Ludovic Courtès
* gnu/system/mapped-devices.scm (<mapped-device-type>)[modules]: New field. (device-mapping-service-type): Honor it. * gnu/system/linux-initrd.scm (raw-initrd): Likewise. Change-Id: Icc702cb6f281741975e33203f87fbc1ffa9856da
2024-01-14mapped-devices: Allow unlocking by a key file.Tomas Volf
Requiring the user to input their password in order to unlock a device is not always reasonable, so having an option to unlock the device using a key file is a nice quality of life change. * gnu/system/mapped-devices.scm (open-luks-device): Add #:key-file argument. (luks-device-mapping-with-options): New procedure. * doc/guix.texi (Mapped Devices): Describe the new procedure. Change-Id: I1de4e045f8c2c11f9a94f1656e839c785b0c11c4 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2022-04-08mapped-devices: Ensure 'cryptsetup open' gets a tty.Ludovic Courtès
Fixes <https://issues.guix.gnu.org/54770>. Regression introduced in 400c9ed3d779308e56038305d40cd93acb496180. Previously, for an encrypted /home (say), "cryptsetup open" would be invoked by shepherd, with /dev/null as its standard input. It would thus run in non-interactive mode and, instead of asking for a passphrase, fail with: Nothing to read on input. This change ensures it runs in interactive mode. * gnu/build/file-systems.scm (system*/console, system*/tty): New procedures. * gnu/system/mapped-devices.scm (open-luks-device): Use 'system*/tty' instead of 'system*'.
2021-12-01gnu: system: Add LUKS2 support for the root file system.Josselin Poiret
* gnu/bootloader/grub.scm (grub-configuration-file): Add 'insmod luks2'. * gnu/system/mapped-devices.scm (open-luks-device): Create '/run/cryptsetup/' directory. Signed-off-by: Ludovic Courtès <ludo@gnu.org>