Don't encode the current timestamp. This affects the output of `perl -V`, specifically the message "Compiled at [...]". The 'cf_time' and 'cf_by' values show up in 'config.h' and in 'Config_heavy.pl'. Use the output of 'uname -s' instead of 'uname -a' to avoid recording the kernel version ('uname -o' leads to directory names like 'x86_64-gnulinux' instead of 'x86_64-linux', which might cause breakage down the road.) diff --git a/perl.c b/perl.c index 228a0d8..ed38313 100644 --- a/perl.c +++ b/perl.c @@ -1825,6 +1825,7 @@ S_Internals_V(pTHX_ CV *cv) PUSHs(Perl_newSVpvn_flags(aTHX_ non_bincompat_options, sizeof(non_bincompat_options) - 1, SVs_TEMP)); +#define PERL_BUILD_DATE "Jan 1 1970 00:00:00" #ifndef PERL_BUILD_DATE # ifdef __DATE__ # ifdef __TIME__ --- a/Configure 1970-01-01 01:00:00.000000000 +0100 +++ b/Configure 2016-10-01 14:47:20.017319739 +0200 @@ -3276,7 +3276,7 @@ $eunicefix tr : Try to determine whether config.sh was made on this system case "$config_sh" in '') -myuname=`$uname -a 2>/dev/null` +myuname=`$uname -s 2>/dev/null` $test -z "$myuname" && myuname=`hostname 2>/dev/null` # Downcase everything to avoid ambiguity. # Remove slashes and single quotes so we can use parts of this in @@ -3845,10 +3845,10 @@ . ./posthint.sh : who configured the system -cf_time=`LC_ALL=C; LANGUAGE=C; export LC_ALL; export LANGUAGE; $date 2>&1` +cf_time="1970-01-01" case "$cf_by" in "") - cf_by=`(logname) 2>/dev/null` + cf_by="guix" case "$cf_by" in "") cf_by=`(whoami) 2>/dev/null` ges/specifications.scm?id=dc09170a54cefc876bd63f45c44de39356b84dc0'>diff
path: root/gnu/packages/specifications.scm
AgeCommit message (Collapse)Author
2024-06-30gnu: Add specification-specreduce-data.Sharlatan Hellseher
* gnu/packages/specifications.scm (specification-specreduce-data): New variable. Change-Id: I269cc7eefa12dd8d207da9ac613b5793c3e24c7c
2024-05-23gnu: Add specification-ipld.Sharlatan Hellseher
* gnu/packages/specifications.scm (specification-ipld): New variable. Change-Id: Ib36d0cdb4a6d20da789ba20830945c8a7d223b69
2024-04-12gnu: Add specification-multicodec.Artyom V. Poptsov
* gnu/packages/specifications.scm (specification-multicodec): New variable. Change-Id: I75de43613c5a1818b1db79aa275c58dc52411957 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
2024-04-12gnu: Add specification-multihash.Artyom V. Poptsov
* gnu/packages/specifications.scm (specification-multihash): New variable. Change-Id: I065898164cc126445a92b33dd628ab06e19d0615 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
2024-04-06gnu: Add specification-multibase.Artyom V. Poptsov
* gnu/packages/specifications.scm: New module. (specification-multibase): New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Add "gnu/packages/specifications.scm". Change-Id: I5994e8f8927d5365cc201da30bd49abf03d17574 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>