Fix Perl module Module::Pluggable such that it can find plugins that live in symlinked directories. Patch borrowed/adapted from Nixpkgs. --- Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500 +++ Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500 @@ -164,7 +164,7 @@ my $sp = catdir($dir, (split /::/, $searchpath)); # if it doesn't exist or it's not a dir then skip it - next unless ( -e $sp && -d _ ); # Use the cached stat the second time + next unless ( -e $sp ); my @files = $self->find_files($sp); @@ -279,7 +279,7 @@ (my $path = $File::Find::name) =~ s#^\\./##; push @files, $path; } - }, $search_path ); + }, "$search_path/." ); } #chdir $cwd; return @files;ustomized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/system/file-systems.scm
AgeCommit message (Expand)Author
2018-06-14install: Use (guix store database) instead of 'guix-register'....Ludovic Courtès
2018-05-28file-systems: Remove 'title' field and add <file-system-label>....Ludovic Courtès
2018-05-19file-systems: Do not export <file-system>....Ludovic Courtès
2018-04-29file-systems: Expound '%pseudo-file-system-types'....Ludovic Courtès
2018-04-27guix system: Report wrong file system 'device' fields....Ludovic Courtès
2017-12-22file-systems: Move %control-groups from %base-file-systems to...Mathieu Othacehe
2017-12-22file-systems: Do not mount hugetlb cgroup filesystem....Mathieu Othacehe
2017-10-11file-systems: Preserve UUID types when serializing....Ludovic Courtès
2017-10-05file-systems: Add a 'location' field to <file-system>....Ludovic Courtès
2017-09-11system: Introduce a disjoint UUID type....Ludovic Courtès
2017-09-11file-systems: Introduce (gnu system uuid)....Ludovic Courtès
2017-03-21file-systems: Add missing docstring....Ludovic Courtès
2017-03-21file-systems: Do not use (gnu packages …)....Ludovic Courtès
2017-03-18file-systems: Factorize file-system-packages....Danny Milosavljevic