Fix Perl module Module::Pluggable such that it can find plugins that live in
symlinked directories.
Patch borrowed/adapted from Nixpkgs.
--- Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500
+++ Module-Pluggable-5.2/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500
@@ -164,7 +164,7 @@
my $sp = catdir($dir, (split /::/, $searchpath));
# if it doesn't exist or it's not a dir then skip it
- next unless ( -e $sp && -d _ ); # Use the cached stat the second time
+ next unless ( -e $sp );
my @files = $self->find_files($sp);
@@ -279,7 +279,7 @@
(my $path = $File::Find::name) =~ s#^\\./##;
push @files, $path;
}
- }, $search_path );
+ }, "$search_path/." );
}
#chdir $cwd;
return @files;
|
Age | Commit message (Expand) | Author |
2020-10-03 | gnu: nyacc: Use versioned Guile site directory....This is a follow-up to commit 4e896da45d7be42ff1ad0b2be741b168573e6f0e.
* gnu/packages/mes.scm (nyacc)[source]: Add snippet.
| Ricardo Wurmus |
2020-09-25 | gnu: nyacc: Add 1.03.0....* gnu/packages/mes.scm (nyacc): Rename to...
(nyacc-0.99): ... this.
(nyacc): New variable.
(mes)[propagated-inputs]: Replace NYACC with NYACC-0.99.
(mes-rb5)[native-inputs]: Likewise.
* gnu/packages/commencement.scm (mes-boot)[native-inputs]: Likewise.
(tcc-boot0)[native-inputs]: Likewise.
| Ludovic Courtès |